Introduction

This help document is intended to provide in-depth information and reference material for the Keysight MD2 LabVIEW Driver.

Contents:

Programming Guide

Programming Reference

© Keysight Technologies, Inc. 2012-2016

Part No: M9700-90004

Version: Thursday, April 28, 2016


Programming Guide

This section provides information and examples for using the MD2 LabVIEW G Driver.

Scenarios and Sample Programs

Example: Simple Acquisition

Example: Multi Record Acquisition

Example: Averager

Example: Peak Detection

Example: DDC


Scenarios and Sample Programs

The following example programs are provided to demonstrate certain features in a typical AgMD2 supported Digitizer.

Each example VI has a front panel you can use to exercise the underlying VI functions.

Example: Simple Acquisition

Example: Multi Record Acquisition

Example: Averager

Example: Peak Detection

Example: DDC


AgMD2 : Simple Acquisition

This example initializes the instrument, reads a few Identity interface properties, and performs a simple acquisition.


AgMD2 : Multi Record Acquisition

This example initializes the instrument, reads a few Identity interface properties, and performs a multi record acquisition.


AgMD2 : Averager

This example initializes the instrument, reads a few Identity interface properties and performs an accumulated acquisition.

The Averager features are not supported in simulation mode. You will have to update the resource string (resource[]) to match your configuration and disable the simulation mode (options[] - set Simulate=false) to be able to run this example successfully.


AgMD2 : Peak Detection

This example initializes the instrument, reads a few Identity interface properties, and performs an acquisition with peak detection.

The PeakDetection features are not supported in simulation mode. You will have to update the resource string (resource[]) to match your configuration and disable the simulation mode (options[] - set Simulate=false) to be able to run this example successfully.


AgMD2 : DDC

This example performs a multi-record acquisition using the Digital Down Conversion (DDC) mode. The DDC features are not supported in simulation mode. It requires a real instrument having the "DDC" option and an input signal on "Channel1" with a modulated pulse centered at 100 Mhz and an amplitude of 6 dBm.


Programming Reference

This section provides information on each of the VIs and the associated Attributes in the MD2 LabVIEW G Driver.

AgMD2 Methods (VIs)

VI Tree

Initialize

Initialize With Options

Close

Action-Status

Configure

Data

Utility

AgMD2 Attributes

ACQUISITION_DATA_LOCK

ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED

ACQUISITION_MODE

ACQUISITION_NUMBER_OF_AVERAGES

ACTIVE_TRIGGER_SOURCE

BASELINE_CORRECTION_DIGITAL_OFFSET

BASELINE_CORRECTION_MODE

BASELINE_CORRECTION_THRESHOLD_HIGH

BASELINE_CORRECTION_THRESHOLD_LOW

BOARD_TEMPERATURE

CALIBRATION_IS_REQUIRED

CHANNEL_CONNECTOR_NAME

CHANNEL_COUNT

CHANNEL_DATA_INVERSION_ENABLED

CHANNEL_ENABLED

CHANNEL_TEMPERATURE

CONTROL_IO_AVAILABLE_SIGNALS

CONTROL_IO_COUNT

CONTROL_IO_SIGNAL

CSR_ENABLED

CSR_STOP_MODE

DDCCORE_CENTER_FREQUENCY

DDCCORE_COUNT

DDCCORE_DATA_SOURCE

DDCCORE_DECIMATION_DENOMINATOR

DDCCORE_DECIMATION_NUMERATOR

DDCCORE_LO_INITIAL_PHASE

DELAY_CONTROL_COUNT

DELAY_CONTROL_ENABLED

DELAY_CONTROL_MAX

DELAY_CONTROL_MIN

DELAY_CONTROL_RANGE

DELAY_CONTROL_VALUE

DRIVER_SETUP

INPUT_CONNECTOR_SELECTION

INPUT_FILTER_BYPASS

INPUT_FILTER_MAX_FREQUENCY

INPUT_FILTER_MIN_FREQUENCY

INPUT_IMPEDANCE

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_INFO_CHASSIS_NUMBER

INSTRUMENT_INFO_IO_VERSION

INSTRUMENT_INFO_NBR_ADC_BITS

INSTRUMENT_INFO_OPTIONS

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_INFO_SLOT_NUMBER

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_FIXED_LATENCY_ENABLED

IO_RESOURCE_DESCRIPTOR

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_ARM

IS_WAITING_FOR_TRIGGER

LOGIC_DEVICE_COUNT

LOGIC_DEVICE_FIRMWARE_STORE_COUNT

LOGIC_DEVICE_IFDL_COUNT

LOGIC_DEVICE_IFDL_ENABLED

LOGIC_DEVICE_IFDL_IS_ACTIVE

LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL

LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE

LOGIC_DEVICE_MEMORY_BANK_COUNT

LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED

LOGIC_DEVICE_SAMPLES_UNSIGNED

LOGIC_DEVICE_STREAM_MODE

LOGIC_DEVICE_STREAMS_COUNT

LOGICAL_NAME

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MIN_RECORD_SIZE

MODULE_SYNCHRONIZATION_HANDLE

MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE

MONITORING_VALUE_COUNT

MONITORING_VALUE_CURRENT_VALUE

MONITORING_VALUE_LIMIT_HIGH

MONITORING_VALUE_LIMIT_LOW

MONITORING_VALUE_UNIT

NSA_ENABLED

NSA_NOISE_BASE

NSA_THRESHOLD

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED

PEAK_DETECTION_FALLING_DELTA

PEAK_DETECTION_RISING_DELTA

QUERY_INSTRUMENT_STATUS

RECORD_SIZE

REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

REFERENCE_OSCILLATOR_OUTPUT_ENABLED

REFERENCE_OSCILLATOR_SOURCE

SAMPLE_CLOCK_EXTERNAL_DIVIDER

SAMPLE_CLOCK_EXTERNAL_FREQUENCY

SAMPLE_CLOCK_OUTPUT_ENABLED

SAMPLE_CLOCK_SOURCE

SAMPLE_RATE

SELF_TRIGGER_MODE

SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE

SELF_TRIGGER_SQUARE_WAVE_FREQUENCY

SELF_TRIGGER_SQUARE_WAVE_SLOPE

SIMULATE

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

STREAM_COUNT

STREAM_ENABLED

STREAM_GRANULARITY_IN_BYTES

STREAM_MARKERS_BITS_PER_MARKER

STREAM_MARKERS_FRACTIONAL_BITS

STREAM_MAX_SIZE_IN_BYTES

STREAM_MINMAX_FRAME_SIZE

STREAM_SAMPLES_BITS_PER_SAMPLE

STREAM_SAMPLES_DATA_EMULATION_ENABLED

STREAM_SAMPLES_DATA_EMULATION_RATE

STREAM_SAMPLES_DATA_TRUNCATION_BIT_COUNT

STREAM_SAMPLES_DATA_TRUNCATION_ENABLED

STREAM_SAMPLES_DATA_TRUNCATION_KEEP_MSB

STREAM_TYPE

SUPPORTED_INSTRUMENT_MODELS

TEMPERATURE_UNITS

TIME_INTERLEAVED_CHANNEL_LIST

TIME_INTERLEAVED_CHANNEL_LIST_AUTO

TRIGGER_COUPLING

TRIGGER_DELAY

TRIGGER_HOLDOFF

TRIGGER_HYSTERESIS

TRIGGER_LEVEL

TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES

TRIGGER_MAGNITUDE_SLOPE

TRIGGER_OUTPUT_ENABLED

TRIGGER_OUTPUT_OFFSET

TRIGGER_OUTPUT_SOURCE

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_OPERATOR

TRIGGER_TYPE

TSR_ENABLED

TSR_IS_ACQUISITION_COMPLETE

TSR_MEMORY_OVERFLOW_OCCURRED

USER_CONTROL_COUNTERS_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

USER_CONTROL_POST_TRIGGER

USER_CONTROL_PRE_TRIGGER

USER_CONTROL_START_ON_TRIGGER_ENABLED

USER_CONTROL_TRIGGER_ENABLE_SOURCE

USER_CONTROL_TRIGGER_FACTOR

USER_CONTROL_TRIGGER_SELECTION

VERTICAL_COUPLING

VERTICAL_OFFSET

VERTICAL_RANGE


Keysight AgMD2 Methods (VIs)

This section provides technical and programming support for using the Keysight AgMD2 LabVIEW API VIs to develop applications for your Digitizers.

The VIs are split into the following main topics, depending on their function:

VI Tree

Initialize

Initialize With Options

Close

Action-Status

Acquisition

Abort

Apply Setup

Arm Data Lock

Initiate Acquisition

Unlock Data

Wait For Acquisition Complete

Logic Device

Get Logic Device IFDL Name

Get Logic Device Memory Bank Name

Get Logic Device Name

Logic Device Get Buffer Addresses

Logic Device Get Core Version

Logic Device IFDL Check Self Test Receiver

Logic Device IFDL Start Self Test Receiver

Logic Device IFDL Start Self Test Transmitter

Logic Device Load From File

Logic Device Write Firmware Store From File

Logic Device Write Indirect Int32

Logic Device Write Register Int32

Logic Device Write Stream Waveform Int16

Logic Device Write Stream Waveform Int8

Self Trigger

Self Trigger Abort Generation

Self Trigger Initiate Generation

Status

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger

User Control

User Control Start Processing

User Control Start Segmentation

User Control Stop Processing

User Control Stop Segmentation

User Control Wait For Processing Complete

User Control Write Control Register Int32

Get Channel Name

Get ControlIO Name

Get DDCCore Name

Get Delay Control Name

Get Monitoring Value Name

Get Stream Name

Get Trigger Source Name

Module Synchronization Get Slaves

Send Software Arm

Send Software Trigger

TSR Continue

Configure

Low Level

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString

Reference Oscillator

Configure Reference Oscillator Output Enabled

Configure Reference Oscillator

Sample Clock

Configure Sample Clock Output Enabled

Configure Sample Clock

Self Trigger

Self Trigger Custom Wave Load Configuration File

Self Trigger Square Wave Configure

Trigger

Configure Edge Trigger Source

Configure Pretrigger Samples

Configure Trigger Holdoff

Trigger Magnitude Configure

Baseline Correction Configure

Configure Acquisition Record

Configure Channel

Configure Input Filter

Configure Temperature Units

Configure Time Interleaved Channel List

Logic Device Configure Buffer Addresses

Module Synchronization Configure Slaves

NSA Configure

Peak Detection Configure

Data

Fetch

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Int8

Fetch Waveform Real64

Fetch Accumulated

Fetch Accumulated Waveform Int32

Fetch Accumulated Waveform Real 64

Fetch DDCCore

DDCCore Fetch Waveform Int16

DDCCore Fetch Waveform Int32

Fetch Multi-Record

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Real64

Logic Device

Logic Device Playback Stream Waveforms

Logic Device Read Indirect Int32

Logic Device Read Register Int32

Read

Read Waveform Int16

Read Waveform Int32

Read Waveform Int8

Read Waveform Real64

Module Synchronization Get Slaves

Stream Fetch Data Int32

User Control Read Control Register Int32

Utility

Calibration

Calibration Cancel

Calibration Load From File

Calibration Save To File

Self Calibrate

Instrument Info

Instrument Info Attribute ID Value From String

Instrument Info Attribute ID Value To String

Disable

Error Message

Error-Query

Query Board Temperature

Query Channel Temperature

Query Min Waveform Memory

Reset

Reset With Defaults

Revision Query

Self-Test


AgMD2 : VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


AgMD2 : Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Inputs

resource string

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Keysight Connection Expert. To configure an IVI session or IVI logical name, consult the IVI tools on your system, such as NI-MAX(Keysight devices may not appear in NI Max).

id query (Off)

Specifies whether to verify the ID of the instrument.

reset device (Off)

Specifies whether to reset the instrument.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

Unique identifier for an IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Initialize With Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Supported Models: All supported

Inputs

resource string

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form: PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Keysight Connection Expert. To configure an IVI session or IVI logical name, consult the IVI tools on your system, such as NI-MAX(Keysight devices may not appear in NI Max).

id query (Off)

Specifies whether to verify the ID of the instrument.

reset device (Off)

Specifies whether to reset the instrument.

option string

Use to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameter is "Name=Value", where Name is one of

Name | Value
RangeCheck | True/False
QuerytInstrStatus | True/False
Cache | True/False
Simulate | True/False
RecordCoercions | True/False
InterchangeCheck | True/False
DriverSetup | (see below)

If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

Unique identifier for an IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Action Status

Contained in this section are VIs which control the status or initiate actions within the instrument.

Acquisition

Abort

Apply Setup

Arm Data Lock

Initiate Acquisition

Unlock Data

Wait For Acquisition Complete

Logic Device

Get Logic Device IFDL Name

Get Logic Device Memory Bank Name

Get Logic Device Name

Logic Device Get Buffer Addresses

Logic Device Get Core Version

Logic Device IFDL Check Self Test Receiver

Logic Device IFDL Start Self Test Receiver

Logic Device IFDL Start Self Test Transmitter

Logic Device Load From File

Logic Device Write Firmware Store From File

Logic Device Write Indirect Int32

Logic Device Write Register Int32

Logic Device Write Stream Waveform Int16

Logic Device Write Stream Waveform Int8

Self Trigger

Self Trigger Abort Generation

Self Trigger Initiate Generation

Status

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger

User Control

User Control Start Processing

User Control Start Segmentation

User Control Stop Processing

User Control Stop Segmentation

User Control Wait For Processing Complete

User Control Write Control Register Int32

Get Channel Name

Get ControlIO Name

Get DDCCore Name

Get Delay Control Name

Get Monitoring Value Name

Get Stream Name

Get Trigger Source Name

Module Synchronization Get Slaves

Send Software Arm

Send Software Trigger

TSR Continue


Acquisition

Contained in this section are acquisition-related VIs.

Abort

Apply Setup

Arm Data Lock

Initiate Acquisition

Unlock Data

Wait For Acquisition Complete


AgMD2 : Abort

Aborts an acquisition and returns the digitizer to the Idle state.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Apply Setup

Applies directly the configured properties setup to the instrument.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Remarks:

No configuration change is immediately applied to the instrument hardware. This means that setting any attribute only changes the 'setup' in the driver, and an explicit call to Apply Setup is required to have the change be effective in the instrument hardware.

There are some exceptions for actions: VIs that perform an action, which, for example, also modify the instrument's state. Currently, the following functions do perform an implicit ApplySetup before the actual action:

VI Name | Description
Self Test | To ensure the instrument is actually in the desired state before doing the self test.
Self Calibrate | To ensure the instrument is actually in the desired state before self-calibrating.
Initiate Acquisition | To apply the configured setup to the instrument hardware before starting the measurement.
Read | All Read methods start by performing an Initiate followed by Wait and then Fetch.


AgMD2 : Arm Data Lock

This function is private and for Keysight-internal use only.

Supported Models: M9703B, M9709A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Initiate Acquisition

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Unlock Data

This function is private and for Keysight-internal use only.

Supported Models: M9703B, M9709A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Wait For Acquisition Complete

Waits until the configured acquisition is complete. If no acquisition is currently running, this VI returns immediately. If the acquisition does not complete within the time period the user specified with the Maximum Time parameter, the VI returns the Max Time Exceeded error.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Maximum Time

Specifies the maximum time the end-user allows for this VI to complete. The units are milliseconds. Defined value: Max Time Infinite - The function waits indefinitely for the acquisition to complete.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Logic Device

Contained in this section are VIs related to LogicDevice.

Get Logic Device IFDL Name

Get Logic Device Memory Bank Name

Get Logic Device Name

Logic Device Get Buffer Addresses

Logic Device Get Core Version

Logic Device IFDL Check Self Test Receiver

Logic Device IFDL Start Self Test Receiver

Logic Device IFDL Start Self Test Transmitter

Logic Device Load From File

Logic Device Write Firmware Store From File

Logic Device Write Indirect Int32

Logic Device Write Register Int32

Logic Device Write Stream Waveform Int16

Logic Device Write Stream Waveform Int8


AgMD2: Get Logic Device IFDL Name

Returns the Logic Device IFDL name that corresponds to the one-based index that the user specifies.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDeviceIFDL

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDeviceIFDL.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.


AgMD2: Get Logic Device Memory Bank Name

Returns the Logic Device Memory Bank name that corresponds to the one-based index that the user specifies.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDeviceMemoryBank

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDeviceMemoryBank.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.


AgMD2 : Get Logic Device Name

Returns the logic device name that corresponds to the one-based index that the user specifies.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2: Logic Device Get Buffer Addresses

Retrieves the indirect buffer addresses.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

BufferId

The firmware indirect buffer id. Only buffers 16 to 31 can be configured.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Base

The firmware indirect buffer base address.

Limit

The firmware indirect buffer limit address.


AgMD2: Logic Device Get Core Version

Retrieves the version of the given core.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

CoreId (PCIe)

The firmware Core Identifier.

Defined Values For CoreId:

  • LOGIC_DEVICE_CORE_PCIE(0) : Identifier for the LogicDevice PCIe Core.
  • LOGIC_DEVICE_CORE_DDR3A(1) : Identifier for the LogicDevice DDR3 bank A Core.
  • LOGIC_DEVICE_CORE_DDR3B(2) : Identifier for the LogicDevice DDR3 bank B Core.
  • LOGIC_DEVICE_CORE_CALIBRATION_DIGITIZER(3) : Identifier for the LogicDevice Calibration Digitizer Core.
  • LOGIC_DEVICE_CORE_IFDL_UP(4) : Identifier for the LogicDevice IFDL Up Core.
  • LOGIC_DEVICE_CORE_IFDL_DOWN(5) : Identifier for the LogicDevice IFDL Down Core.
  • LOGIC_DEVICE_CORE_IFDL_CONTROL(6) : Identifier for the LogicDevice IFDL Control Core.
  • LOGIC_DEVICE_CORE_QDR2(7) : Identifier for the LogicDevice QDR2 Core.
  • LOGIC_DEVICE_CORE_ADC_INTERFACE(8) : Identifier for the LogicDevice ADC Interface Core.
  • LOGIC_DEVICE_CORE_STREAM_PREPARE(9) : Identifier for the LogicDevice Stream Prepare Core.
  • LOGIC_DEVICE_CORE_TRIGGER_MANAGER(10) : Identifier for the LogicDevice Trigger Manager Core.

VersionStringBufferSize

Number of elements in VersionString.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Version

The version number, with bits 0-15 stating minor version number, and bits 16-30 stating major version number.

VersionString

The version number, as a string.


AgMD2: Logic Device IFDL Check Self Test Receiver

Checks whether the IFDL Receiver has correctly received data from the Transmitter.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDeviceIFDL

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDeviceIFDL.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Val

True if the test passes.


AgMD2: Logic Device IFDL Start Self Test Receiver

Starts the IFDL Receiver mode for Self Test.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDeviceIFDL

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDeviceIFDL.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Logic Device IFDL Start Self Test Transmitter

Starts the IFDL Transmitter mode for Self Test.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDeviceIFDL

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDeviceIFDL.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2 : Logic Device Load From File

Loads the bitfile to the logic device.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

LogicDevice

The physical or virtual repeated capability identifier. Pass an empty string if the operation does not apply to a repeated capability. You can also pass an empty string if the device only has a single Logic Device.

Path

Specifies the path of the bitfile location.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2: Logic Device Write Firmware Store From File

Stores in the given Firmware Config the Firmware from given File.

Supported Models: M9205A, M9206A, M9703A, M9710A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

FirmwareStore (1)

One-based index in the list of Firmware Stores.

Path

Path to the file containing the Firmware.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Logic Device Write Indirect Int32

Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by Logic Device repeated capability.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

DataBufferSize

Number of elements in data.

Id

The firmware indirect buffer id.

StartAddress

The start address in the FPGA where the data will be written.

NumElements

Number of elements to write.

Data

Buffer containing data to write into the firmware indirect buffer.

Numeric

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Logic Device Write Register Int32

Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by Logic Device repeated capability.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

Offset

Address in the FPGA where the register will be written.

Value

Value to write into the register.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Logic Device Write Stream Waveform Int16

Writes an array of Samples into a given Stream to be emulated.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

SamplesBufferSize

Number of elements in Samples.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

Stream (1)

One-based index in the list of Streams.

Samples

Array containing the Samples to upload into the Stream.

Numeric

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Logic Device Write Stream Waveform Int8

Writes an array of Samples into a given Stream to be emulated.

Supported Models: M9205A, M9206A, M9703A, M9710A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

Stream (1)

One-based index in the list of Streams.

SamplesBufferSize

Number of elements in Samples.

Samples

Array containing the Samples to upload into the Stream.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


Self Trigger

Contained in this section are VIs related to Self Trigger.

Self Trigger Abort Generation

Self Trigger Initiate Generation


AgMD2: Self Trigger Abort Generation

Stops the generation of the self-trigger signal previously initiated.

Supported Models: U5303A, U5309A, U5310A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

TriggerSource

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single trigger source.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Self Trigger Initiate Generation

Starts the generation of the self-trigger signal.

Supported Models: U5303A, U5309A, U5310A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

TriggerSource

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single trigger source.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


Status

Contained in this section are VIs which determine the state of the digitizer.

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger


AgMD2 : Is Idle

Determines if the digitizer is currently in the Idle state.

Supported Models: All Supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Idle state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
True (1) | The digitizer is currently in the Idle state.
False (2) | The digitizer is not currently in the Idle state.
Unknown (3) | The driver cannot query the instrument to determine the digitizer state.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Is Measuring

Determines if the digitizer is currently in the Measuring state.

Supported Models: All Supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Measuring state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
True (1) | The digitizer is currently in the Measuring state.
False (2) | The digitizer is not currently in the Measuring state.
Unknown (3) | The driver cannot query the instrument to determine the digitizer state.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Is Waiting For Arm

Determines if the digitizer is currently in the Waiting For Arm state.

Supported Models: All Supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the WaitingForArm state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
True (1) | The digitizer is currently waiting for Arm.
False (2) | The digitizer is not currently waiting for Arm.
Unknown (3) | The driver cannot query the instrument to determine the digitizer state.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Is Waiting For Trigger

Determines if the digitizer is currently in the Waiting For Trigger state.

Supported Models: All Supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Waiting For Trigger state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
True (1) | The digitizer is currently waiting for Trigger.
False (2) | The digitizer is not currently waiting for Trigger.
Unknown (3) | The driver cannot query the instrument to determine the digitizer state.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


User Control

Contained in this section are VIs related to User Control.

User Control Start Processing

User Control Start Segmentation

User Control Stop Processing

User Control Stop Segmentation

User Control Wait For Processing Complete

User Control Write Control Register Int32


AgMD2 : User Control Start Processing

Sends the Start command for the given Processing Type.

Supported Models:M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ProcessingType (1)

The type of Processing to be started.

Defined Values For Parameter ProcessingType :

  • USER_CONTROL_PROCESSING_TYPE1(1) : UserControl Processing Type 1.
  • USER_CONTROL_PROCESSING_TYPE2(2) : UserControl Processing Type 2.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


AgMD2 : User Control Start Segmentation

Starts the segmentation mechanism.

Supported Models:M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


AgMD2 : User Control Stop Processing

Sends the Stop command for the given Processing Type.

Supported Models:M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ProcessingType (1)

The type of Processing to be started.

Defined Values For Parameter ProcessingType :

  • USER_CONTROL_PROCESSING_TYPE1(1) : UserControl Processing Type 1.
  • USER_CONTROL_PROCESSING_TYPE2(2) : UserControl Processing Type 2.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


AgMD2 : User Control Stop Segmentation

Stops the segmentation mechanism.

Supported Models:M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


AgMD2 : User Control Wait For Processing Complete

Waits until the given Processing Type is complete. If this processing is not currently running, this function returns immediately. If the processing does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the VI returns the Max Time Exceeded error.

Supported Models: M9205A, M9206A, M9703A, M9710A, U5307A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

Specifies the LogicDevice this function has to wait upon. It must be equal to one of the LogicDevice repeated capability string.

ProcessingType (1)

The type of Processing to be waited upon.

Defined Values are :

Type1 (1) : UserControl Processing Type 1

Type2 (2) : UserControl Processing Type 2

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this function to complete. The units are milliseconds. Defined values: IviDigitizerTimeOutInfinite (-1) - The function waits indefinitely for the acquisition to complete.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


AgMD2 : User Control Write Control Register Int32

Writes the given Value to the User Control register at given Offset.

Supported Models:M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Offset

Offset in the User Control FPGA where the register will be written.

Value

Value to write to the register.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


AgMD2 : Get Channel Name

Returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the VI returns an empty string in the Name parameter and returns an error.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Index (1)

A one-based index that defines which name to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Channel Name

A string containing the channel name.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Control IO Name

Returns the Control IO Connector name that corresponds to the one-based index that the user specifies.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get DDCCore Name

Returns the DDC core name that corresponds to the one-based index that the user specifies.

Supported Models: All Supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Delay Control Name

Returns the delay control name that corresponds to the one-based index that the user specifies.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Monitoring Value Name

Returns the Monitoring Value name that corresponds to the one-based index that the user specifies.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Stream Name

Returns the stream name that corresponds to the one-based index that the user specifies.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9710A, U5303A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index (1)

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Trigger Source Name

Returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the VI returns an empty string in the Name parameter and returns an error.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Source Index (1)

A one-based index that defines which name to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Source Name

Specifies a buffer into which the driver stores the channel name.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Module Synchronization Get Slaves

Retrieves the handles of the Slave modules which are synchronized with the current master. If the current module is a synchronized slave, or is not a synchronized module, then no slaves are returned.

Supported Models: M9703B, M9709A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

SlavesBufferSize

Number of elements in Slaves.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Slaves

Array of Slaves.

Numeric

ActualSlaves

Actual number of elements in Slaves.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Send Software Arm

--NOT SUPPORTED-- This VI follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Send Software Trigger

Sends a software generated trigger to the instrument. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : TSR Continue

Marks the acquired (single- or multi-record) waveform currently available for fetching as no longer needed (for example, once it has been read). This allows the corresponding memory segment(s) to be released and made available for new acquisitions.

Supported Models: M9203A, M9703B, U5303A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Configuration VIs

Contained in this section are VIs which are used to configure the instrument.

Low Level

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString

Reference Oscillator

Configure Reference Oscillator Output Enabled

Configure Reference Oscillator

Sample Clock

Configure Sample Clock Output Enabled

Configure Sample Clock

Self Trigger

Self Trigger Custom Wave Load Configuration File

Self Trigger Square Wave Configure

Trigger

Configure Edge Trigger Source

Configure Pretrigger Samples

Configure Trigger Holdoff

Trigger Magnitude Configure

Baseline Correction Configure

Configure Acquisition Record

Configure Channel

Configure Input Filter

Configure Temperature Units

Configure Time Interleaved Channel List

Logic Device Configure Buffer Addresses

Module Synchronization Configure Slaves

NSA Configure

Peak Detection Configure


Configuration \ Low-level VIs

Contained in this section are VIs which are used to access the low-level operations of the instrument.

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString


AgMD2 : Get Attribute ViBoolean

Gets a Boolean attribute from the instrument driver.

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED: Not Supported - Enables or disables the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
  • CALIBRATION_IS_REQUIRED: Read Only - Returns whether or not a self calibration is required.
  • CHANNEL_DATA_INVERSION_ENABLED: Specifies whether the data acquired is inverted.
  • CHANNEL_ENABLED: Specifies whether the digitizer acquires a waveform for the channel.
  • CSR_ENABLED: Specifies whether the CSR mode is enabled on the instrument.
  • DELAY_CONTROL_ENABLED: Not Supported - Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
  • INPUT_FILTER_BYPASS: Specifies whether or not to bypass the input filter.
  • IO_FIXED_LATENCY_ENABLED: Specifies whether the IO input is propagated to the DPUs with potentially variable latency or with guaranteed fixed latency.
  • LOGIC_DEVICE_IFDL_ENABLED: Specifies whether the IFDL is enabled.
  • LOGIC_DEVICE_IFDL_IS_ACTIVE: Read Only - Returns whether the IFDL is currently active.
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED: Enables the FIFO mode for MemoryBank. Used when streaming.
  • LOGIC_DEVICE_SAMPLES_UNSIGNED: When True, directs the LogicDevice to receive unsigned samples values from the ADC.
  • NSA_ENABLED: Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the ACQUISITION_MODE attribute is set to Averager.
  • PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED: Specifies whether the amplitude value of the peak (in ADC counts) should be accumulated instead of a fixed value of 1 for a detected peak.
  • QUERY_INSTRUMENT_STATUS: If True, the driver queries the instrument status at the end of each VI that performs I/O to the instrument. If an error is reported, use Error Query to retrieve error messages, one at a time, from the instrument.
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED: Specifies whether or not the reference frequency signal appears at an output of the digitizer.
  • SAMPLE_CLOCK_OUTPUT_ENABLED: Specifies whether or not the sample clock appears at a reference output of the digitizer.
  • SIMULATE: If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
  • STREAM_ENABLED: Specifies whether the stream is enabled on the instrument.
  • STREAM_SAMPLES_DATA_EMULATION_ENABLED: Specifies whether the Data Emulation is enabled. If True, the output data is fetched from an internal ramp waveform generator. If False, the output data is fetched from the digitizer ADC stream.
  • STREAM_SAMPLES_DATA_TRUNCATION_ENABLED: Specifies whether the Data Truncation is enabled.
  • STREAM_SAMPLES_DATA_TRUNCATION_KEEP_MSB: Specifies whether the output stream element contains the most significant or the least significant bits of the raw digitizer data sample. Ignored if STREAM_SAMPLES_DATA_TRUNCATION_ENABLED is False.
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO: Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
  • TRIGGER_OUTPUT_ENABLED: Specifies whether or not an accepted trigger appears at an output of the digitizer.
  • TSR_ENABLED: Specifies whether TSR operation is enabled on the instrument.
  • TSR_IS_ACQUISITION_COMPLETE: Read Only - Indicates if a (single- or multi-record) waveform can be fetched from the instrument. Applicable only when TSR operation is enabled.
  • TSR_MEMORY_OVERFLOW_OCCURED: Read Only - Indicates that no memory segment was available to acquire new data. The instrument could therefore not accept any new triggers, and some might have been missed.
  • USER_CONTROL_START_ON_TRIGGER_ENABLED: Specifies whether the segmentation mechanism should work in Start On Trigger mode. While in Start On Trigger mode, the PreTrigger value is ignored.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViInt32

Gets an Int32 attribute from the instrument driver.

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_MODE: The acquisition mode. Defined values for ACQUISTION_MODE are : 0 - Normal , 1 - Averager, 2 - PeakDetection, 3 - BaseBand0, 4 - DigitalDownConversion and F - UserFDK
  • ACQUISITION_NUMBER_OF_AVERAGES: Specifies the number of waveforms to average in the record. This attribute affects instrument behavior only when the ACQUISITION MODE attribute is set to AVERAGER or PEAK_DETECTION.
  • BASELINE_CORRECTION_DIGITAL_OFFSET: Applies a digital offset after the baseline correction.
  • BASELINE_CORRECTION_MODE: Defines the mode used during baseline correction accumulation. Defined values are: Disabled (0), Continous (1), and Between Acquisition (2).
  • BASELINE_CORRECTION_THRESHOLD_HIGH: Defines the higher limit of the baseline range. Outside of this range, data values are ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts.
  • BASELINE_CORRECTION_THRESHOLD_LOW: Defines the lower limit of the baseline range. Outside of this range, data values are ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts.
  • CHANNEL_COUNT: Read Only - The number of channels present on the instrument.
  • CONTROL_IO_COUNT: Read Only - Returns the number of Control IO Connectors.
  • CSR_STOP_MODE: Specifies the CSR acquisition stop mode. Defined Value is Continous (0).
  • DDCCORE_COUNT: Specifies the number of DDC cores.
  • DELAY_CONTROL_COUNT: Read Only - Returns the number of delay controls.
  • DELAY_CONTROL_MAX: Not Supported - Maximum value (DAC code) that can be set for the delay control.
  • DELAY_CONTROL_MIN: Not Supported -Minimum value (DAC code) that can be set for the delay control.
  • DELAY_CONTROL_RANGE: Not Supported - Selects the range for the delay control. Useful only for delay controls with multiple ranges.
  • DELAY_CONTROL_VALUE: Not Supported - The value (DAC code) set for the delay control.
  • INPUT_CONNECTOR_SELECTION: Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.
  • INSTRUMENT_INFO_CHASSIS_NUMBER: Read Only - Chassis number.
  • INSTRUMENT_INFO_NBR_ADC_BITS: Read Only - Number of bits of data per sample from this module's ADCs.
  • INSTRUMENT_INFO_SLOT_NUMBER: Read Only - Slot number of the instrument in the chassis.
  • IS_IDLE: Read Only - Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown. Defined values are True (1), False (2), and Unknown (3).
  • IS_MEASURING: Read Only - Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown. Defined values are True (1), False (2), and Unknown (3).
  • IS_WAITING_FOR_ARM: Not Supported - Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown. Defined values are True (1), False (2), and Unknown (3).
  • IS_WAITING_FOR_TRIGGER: Read Only - Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown. Defined values are True (1), False (2), and Unknown (3).
  • LOGIC_DEVICE_COUNT: Read Only - Returns the number of logic devices.
  • LOGIC_DEVICE_FIRMWARE_STORE_COUNT: Read Only - Number of available firmware stores in the LogicDevice.
  • LOGIC_DEVICE_IFDL_COUNT: Read Only - Returns the number of LogicDevice IFDLs.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL: Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK. Defined Values are Software (0) and User Firmware (1).
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE: When MemoryBank access is controlled by software, specifies how the memory is currently accessed. Defined values are Write (0) and Read (1).
  • LOGIC_DEVICE_MEMORY_BANK_COUNT: Read Only - Number of memory banks in LogicDevice.
  • LOGIC_DEVICE_STREAM_MODE: Specifies the mode the Streams are operating in. Defined Modes are Acquisition (0), Emulation (1) and Sequential (2).
  • LOGIC_DEVICE_STREAMS_COUNT: Number of Streams available in the LogicDevice.
  • MODULE_SYNCHRONIZATION_HANDLE: The handle of the current module.
  • MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE: The handle of the master module, when synchronized. This value will be identical to the attribute Handle if this module is the master, and equal to 0 when not synchronized.
  • MONITORING_VALUE_COUNT: Read Only - Returns the number of MonitoringValues.
  • NSA_NOISE_BASE: Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. The units are ADC counts.
  • NSA_THRESHOLD: Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. The units are ADC counts.
  • PEAK_DETECTION_FALLING_DELTA: Defines the amount by which two consecutive samples must differ to be considered as falling edge in the peak detector algorithm. The units are ADC counts.
  • PEAK_DETECTION_RISING_DELTA: Defines the amount by which two consecutive samples must differ to be considered as rising edge in the peak detector algorithm. The units are ADC counts.
  • REFERENCE_OSCILLATOR_SOURCE: Specifies the reference frequency source used. Defined values are Internal (0), External (1), and AXIeClk100 (4).
  • SAMPLE_CLOCK_SOURCE: Specifies the clock used to pace acquisition sampling. Defined values are Internal (0) and External (1).
  • SELF_TRIGGER_MODE: Defines the self-trigger signal generation mode. Defined values are Custom Wave (0) and Square Wave (1).
  • SELF_TRIGGER_SQUARE_WAVE_SLOPE: Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer. Defined values are Negative (0) and Positive (1).
  • STREAM_COUNT: Returns the number of streams.
  • STREAM_MARKERS_BITS_PER_MARKER: Number of bits representing a Marker value.
  • STREAM_MARKERS_FRACTIONAL_BITS: Number of fractional bits in the Marker value.
  • STREAM_SAMPLES_BITS_PER_SAMPLE: Returns the number of bits per sample.
  • STREAM_SAMPLES_DATA_TRUNCATION_BIT_COUNT: Specifies the size in bits of an output stream element. Ignored if STREAM_SAMPLES_DATA_TRUNCATION_ENABLED is False.
  • STREAM_TYPE: Indicates the type of the stream. Defined values are Markers (0), MinMax (1), & Samples (2).
  • TEMPERATURE_UNITS: Specifies the temperature units returned by the BOARD_TEMPERATURE and the CHANNEL_TEMPERATURE attributes. Defined values are Celsius (0), Fahrenheit (1), and Kelvin (2).
  • TRIGGER_COUPLING: Specifies how the digitizer couples the trigger source. Defined values are AC (0), DC (1), HF Reject (2),LF Reject (3), and Noise reject (4).
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES: Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
  • TRIGGER_MAGNITUDE_SLOPE: Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer. Defined values are Negative (0) and Positive (1).
  • TRIGGER_SLOPE: Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger. Defined values are Negative (0) and Positive (1).
  • TRIGGER_SOURCE_COUNT: Read Only - The number of trigger sources.
  • TRIGGER_SOURCE_OPERATOR: Not Supported - Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.
  • TRIGGER_TYPE: The kind of event that triggers the digitizer. Defined values are Edge (1), Width (2), Runt (3), Glitch (4), TV (5), and Window (6).
  • USER_CONTROL_COUNTERS_MODE: Specifies the Counters Mode. Defined values are Normal (0) and Streaming (1).
  • USER_CONTROL_INTER_SEGMENT_DE LAY_MODE: Specifies how the Inter Segment Delay is managed. In Software mode, the Inter Segment Delay is given as a fixed number of blocks, in the Inter Segment Delay Value attribute. In Firmware mode, the Inter Segment Delay is controlled directly by the User Firmware.
  • USER_CONTROL_INTER_SEGMENT_DELAY_VALUE: Number of Inter Segments Delay blocks.
  • USER_CONTROL_POST_TRIGGER: Number of Post-Trigger blocks.
  • USER_CONTROL_PRE_TRIGGER: Number of Pre-Trigger blocks.
  • USER_CONTROL_TRIGGER_ENABLE_SOURCE: Specifies the Source of the Trigger Enable, either from the Segmentation mechanism, or from the User Firmware. Defined values are Segmentation (0) and User Firmware (1).
  • USER_CONTROL_TRIGGER_FACTOR: Multiplicative factor for the PreTrigger and PostTrigger values, to be used with sparsing. Default value is 1.
  • USER_CONTROL_TRIGGER_SELECTION: Specifies the source of the Trigger, either from the analog circuitry, or from the digital user firmware. Defined values are Analog (0) and Digital (1).
  • VERTICAL_COUPLING: Specifies how the digitizer couples the input signal for the channel. Define values are AC (0), DC (1), and Gnd (2).

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViInt64

Gets an Int64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • DDCCORE_DECIMATION_DENOMINATOR: The denominator of the fractional decimation factor. The decimation factor is applied to the data source sample rate to determine the decimated rate used by the DDC core.

  • DDCCORE_DECIMATION_NUMERATOR: The numerator of the fractional decimation factor. The decimation factor is applied to the data source sample rate to determine the decimated rate used by the DDC core.

  • MAX_FIRST_VALID_POINT_VAL: Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieve the entire acquisition.
  • MAX_SAMPLES_PER_CHANNEL: Read Only - Returns the maximum number of samples per channel that can be captured.
  • MIN_RECORD_SIZE: Read Only - Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, this attribute returns 1.
  • NUM_ACQUIRED_RECORDS: Read Only - Gets the total number of records acquired since the acquisition was last initiated. You may call this method while an acquisition is in progress.
  • NUM_RECORDS_TO_ACQUIRE: Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
  • RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, this attribute returns 1.
  • STREAM_GRANULARITY_IN_BYTES: Indicates the granularity of data for the FetchData operations.
  • STREAM_MAX_SIZE_IN_BYTES: Indicates the maximal size of data for the FetchData operations.
  • STREAM_MINMAX_FRAME_SIZE: Number of samples over which each MinMax pair is computed.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViReal64

Gets a Real64 attribute from the instrument driver.

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • BOARD_TEMPERATURE: Read Only - Indicates the temperature of the entire board. The units are governed by the TEMPERATURE_UNITS attribute.
  • CHANNEL_TEMPERATURE: Read Only - Indicates the temperature of the channel. The units are governed by the TEMPERATURE_UNITS attribute.
  • DDCCORE_CENTER_FREQUENCY : Specifies the center frequency, in Hz, from which the digitizer will downconvert. It sets the local oscillator frequency.
  • DDCCORE_LO_INITIAL_PHASE : The initial phase of the local oscillator the DDC core will use during the downconversion.
  • INPUT_FILTER_MAX_FREQUENCY: Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_FILTER_MIN_FREQUENCY: Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_IMPEDANCE: The input impedance of this channel. The units are Ohms.
  • MONITORING_VALUE_CURRENT_VALUE: Read Only - Returns the current monitored value of the MonitoringValue.
  • MONITORING_VALUE_LIMIT_HIGH: Read Only - Returns the limit value above which the instrument behavior may not be consistent with the specifications.
  • MONITORING_VALUE_LIMIT_LOW: Read Only - Returns the limit value below which the instrument behavior may not be consistent with the specifications.
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER: Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
  • SAMPLE_RATE: Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
  • SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE : Configures the duty cycle of the self trigger square wave signal. Behavior depends on the configuration of the SELF_TRIGGER_SQUARE_WAVE_SLOPE property (for example, if SELF_TRIGGER_SQUARE_WAVE_SLOPE is set to positive, the SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE attribute defines the percentage that the square wave is in the high state). Units are percentage of the period.
  • SELF_TRIGGER_SQUARE_WAVE_FREQUENCY : Specifies the frequency of the self-trigger square wave signal. The units are Hertz.
  • STREAM_SAMPLES_DATA_EMULATION_RATE: Specifies the emulated data rate in samples per seconds. Ignored if the Data Emulation is disabled.
  • TRIGGER_DELAY: Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
  • TRIGGER_HOLDOFF: Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger.
  • TRIGGER_HYSTERESIS: Specifies the trigger hysteresis in Volts.
  • TRIGGER_LEVEL: Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
  • TRIGGER_OUTPUT_OFFSET: Specifies the offset in Volts at the trigger output of the digitizer.
  • VERTICAL_OFFSET: The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
  • VERTICAL_RANGE: The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViString

Gets a String attribute from the instrument driver.

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACTIVE_TRIGGER_SOURCE: Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability.
  • CHANNEL_CONNECTOR_NAME: Read Only - The connector name as it appears on the instrument's front panel.
  • CONTROL_IO_AVAILABLE_SIGNALS: Read Only - Comma separated list of available signal names that can be used for the Signal attribute of this repeated capability.
  • CONTROL_IO_SIGNAL: Signal present on a Control IO connector.
  • DDCCORE_DATA_SOURCE : Selects the input data source used by the DDC core (for example, "Channel1").
  • DRIVER_SETUP: Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
  • INSTRUMENT_FIRMWARE_REVISION: Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
  • INSTRUMENT_INFO_IO_VERSION: Read Only - Version of the IO Driver used by this module.
  • INSTRUMENT_INFO_OPTIONS: Read Only - Comma separated list of options installed in this instrument.
  • INSTRUMENT_INFO_SERIAL_NUMBER_STRING: Read Only - The serial number of the instrument.
  • INSTRUMENT_MANUFACTURER: Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
  • INSTRUMENT_MODEL: Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.
  • IO_RESOURCE_DESCRIPTOR: Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
  • LOGICAL_NAME: Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
  • MONITORING_VALUE_UNIT: Read Only - Returns the unit of this monitoring value.
  • SPECIFIC_DRIVER_DESCRIPTION: Read Only - Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SPECIFIC_DRIVER_REVISION: Read Only - Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SPECIFIC_DRIVER_VENDOR: Read Only - Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SUPPORTED_INSTRUMENT_MODELS: Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
  • TIME_INTERLEAVED_CHANNEL_LIST: This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one or more channel names.
  • TRIGGER_OUTPUT_SOURCE: Selects the trigger signal to drive the trigger output connector on the front panel.

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Boolean

Sets a Boolean attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED: Not Supported - Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
  • CHANNEL_DATA_INVERSION_ENABLED: Specifies whether the data acquired is inverted.
  • CHANNEL_ENABLED: Specifies whether the digitizer acquires a waveform for the channel.
  • CSR_ENABLED: Specifies whether the CSR mode is enabled on the instrument.
  • DELAY_CONTROL_ENABLED: Not Supported - Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
  • INPUT_FILTER_BYPASS: Specifies whether or not to bypass the input filter.
  • IO_FIXED_LATENCY_ENABLED: Specifies whether the IO input is propagated to the DPUs with potentially variable latency or with guaranteed fixed latency.
  • LOGIC_DEVICE_IFDL_ENABLED: Specifies whether the IFDL is enabled.
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED: Enables the FIFO mode for MemoryBank. Used when streaming.
  • LOGIC_DEVICE_SAMPLES_UNSIGNED: When True, directs the LogicDevice to receive unsigned samples values from the ADC.
  • NSA_ENABLED: Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the ACQUISITION_MODE attribute is set to Averager.
  • PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED: Specifies whether the amplitude value of the peak (in ADC counts) should be accumulated instead of a fixed value of 1 for a detected peak.
  • QUERY_INSTRUMENT_STATUS: If True, the driver queries the instrument status at the end of each VI that performs I/O to the instrument. If an error is reported, use Error Query to retrieve error messages, one at a time, from the instrument.
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED: Specifies whether or not the reference frequency signal appears at an output of the digitizer.
  • SAMPLE_CLOCK_OUTPUT_ENABLED: Specifies whether or not the sample clock appears at a reference output of the digitizer.
  • SIMULATE: If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
  • STREAM_ENABLED: Specifies whether the stream is enabled on the instrument.
  • STREAM_SAMPLES_DATA_EMULATION_ENABLED: Specifies whether the Data Emulation is enabled. If True, the output data is fetched from an internal ramp waveform generator. If False, the output data is fetched from the digitizer ADC stream.
  • STREAM_SAMPLES_DATA_TRUNCATION_ENABLED: Specifies whether the Data Truncation is enabled.
  • STREAM_SAMPLES_DATA_TRUNCATION_KEEP_MSB: Specifies whether the output stream element contains the most significant or the least significant bits of the raw digitizer data sample. Ignored if STREAM_SAMPLES_DATA_TRUNCATION_ENABLED is False.
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO: Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the SAMPLE_RATE attribute.
  • TRIGGER_OUTPUT_ENABLED: Specifies whether or not an accepted trigger appears at an output of the digitizer.
  • TSR_ENABLED: Specifies whether TSR operation is enabled on the instrument.
  • USER_CONTROL_START_ON_TRIGGER_ENABLED: Specifies whether the segmentation mechanism should work in Start On Trigger mode. While in Start On Trigger mode, the PreTrigger value is ignored.

AttributeValue (Off)

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Int32

Sets an Int32 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_MODE: The acquisition mode. Defined values for ACQUISTION_MODE are : 0 - Normal , 1 - Averager, 2 - PeakDetection, 3 - BaseBand0, 4 - DigitalDownConversion and F - UserFDK
  • ACQUISITION_NUMBER_OF_AVERAGES: Specifies the number of waveforms to average in the record. This attribute affects instrument behavior only when the ACQUISITION MODE attribute is set to AVERAGER or PEAK_DETECTION.
  • BASELINE_CORRECTION_DIGITAL_OFFSET: Applies a digital offset after the baseline correction.
  • BASELINE_CORRECTION_MODE: Defines the mode used during baseline correction accumulation.
  • BASELINE_CORRECTION_THRESHOLD_HIGH: Defines the higher limit of the baseline range. Outside of this range, data values are ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts.
  • BASELINE_CORRECTION_THRESHOLD_LOW: Defines the lower limit of the baseline range. Outside of this range, data values are ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts.
  • CSR_STOP_MODE: Specifies the CSR acquisition stop mode. Defined Value is Continous (0).
  • DELAY_CONTROL_RANGE: Not Supported - Selects the range for the delay control. Useful only for delay controls with multiple ranges.
  • DELAY_CONTROL_VALUE: Not Supported - The value (DAC code) set for the delay control.
  • INPUT_CONNECTOR_SELECTION: Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL: Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK. Defined Values are Software (0) and User Firmware (1).
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE: When MemoryBank access is controlled by software, this attribute specifies how the memory is currently accessed. Defined values are Write (0) and Read (1).
  • LOGIC_DEVICE_STREAM_MODE: Specifies the mode the Streams are operating in. Defined Modes are Acquisition (0), Emulation (1) and Sequential (2).
  • NSA_NOISE_BASE: Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. The units are ADC counts.
  • NSA_THRESHOLD: Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. The units are ADC counts.
  • PEAK_DETECTION_FALLING_DELTA: Defines the amount by which two consecutive samples must differ to be considered as falling edge in the peak detector algorithm. The units are ADC counts.
  • PEAK_DETECTION_RISING_DELTA: Defines the amount by which two consecutive samples must differ to be considered as rising edge in the peak detector algorithm. The units are ADC counts.
  • REFERENCE_OSCILLATOR_SOURCE: Specifies the reference frequency source used. Defined values are Internal (0), External (1), and AXIeClk100 (4).
  • SAMPLE_CLOCK_SOURCE: Specifies the clock used to pace acquisition sampling. . Defined values are Internal (0) and External (1).
  • SELF_TRIGGER_MODE: Defines the self-trigger signal generation mode. Defined values are Custom Wave (0) and Square Wave (1).
  • SELF_TRIGGER_SQUARE_WAVE_SLOPE: Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer. Defined values are Negative (0) and Positive (1).
  • STREAM_SAMPLES_DATA_TRUNCATION_BIT_COUNT: Specifies the size in bits of an output stream element. Ignored if STREAM_SAMPLES_DATA_TRUNCATION_ENABLED is False.
  • TEMPERATURE_UNITS: Specifies the temperature units returned by the BOARD_TEMPERATURE and the CHANNEL_TEMPERATURE attributes. Defined values are Celsius (0), Fahrenheit (1), and Kelvin (2).
  • TRIGGER_COUPLING: Specifies how the digitizer couples the trigger source. Defined values are AC (0), DC (1), HF Reject (2),LF Reject (3), and Noise reject (4).
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES: Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
  • TRIGGER_MAGNITUDE_SLOPE: Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer. Defined values are Negative (0) and Positive (1).
  • TRIGGER_SLOPE: Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger. Defined values are Negative (0) and Positive (1).
  • TRIGGER_SOURCE_OPERATOR: Not Supported - Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.
  • TRIGGER_TYPE: The kind of event that triggers the digitizer. Defined values are Edge (1), Width (2), Runt (3), Glitch (4), TV (5), and Window (6).
  • USER_CONTROL_COUNTERS_MODE: Specifies the Counters Mode. Defined values are Normal (0) and Streaming (1).
  • USER_CONTROL_INTER_SEGMENT_DELAY_MODE: Specifies how the Inter Segment Delay is managed. In Software mode, the Inter Segment Delay is given as a fixed number of blocks, in the Inter Segment Delay Value attribute. In Firmware mode, the Inter Segment Delay is controlled directly by the User Firmware.
  • USER_CONTROL_INTER_SEGMENT_DELAY_VALUE: Number of Inter Segments Delay blocks.
  • USER_CONTROL_POST_TRIGGER: Number of Post-Trigger blocks.
  • USER_CONTROL_PRE_TRIGGER: Number of Pre-Trigger blocks.
  • USER_CONTROL_TRIGGER_ENABLE_SOURCE: Specifies the Source of the Trigger Enable, either from the Segmentation mechanism, or from the User Firmware. Defined values are Segmentation (0) and User Firmware (1).
  • USER_CONTROL_TRIGGER_FACTOR: Multiplicative factor for the PreTrigger and PostTrigger values, to be used with sparsing. Default value is 1.
  • USER_CONTROL_TRIGGER_SELECTION: Specifies the source of the Trigger, either from the analog circuitry, or from the digital user firmware. Defined values are Analog (0) and Digital (1).
  • VERTICAL_COUPLING: Specifies how the digitizer couples the input signal for the channel. Define values are AC (0), DC (1), and Gnd (2).

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Int64

Sets an Int64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • DDCCORE_DECIMATION_DENOMINATOR: The denominator of the fractional decimation factor. The decimation factor is applied to the data source sample rate to determine the decimated rate used by the DDC core.
  • DDCCORE_DECIMATION_NUMERATOR: The numerator of the fractional decimation factor. The decimation factor is applied to the data source sample rate to determine the decimated rate used by the DDC core.
  • MAX_FIRST_VALID_POINT_VAL: Returns the maximum value that the First Valid Point parameter of the readout VIs may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
  • NUM_RECORDS_TO_ACQUIRE: Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
  • RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.
  • STREAM_MINMAX_FRAME_SIZE: Number of samples over which each MinMax pair is computed.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Real64

Sets a Real64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • DDCCORE_CENTER_FREQUENCY : Specifies the center frequency, in Hz, from which the digitizer will downconvert. It sets the local oscillator frequency.
  • DDCCORE_LO_INITIAL_PHASE : The initial phase of the local oscillator the DDC core will use during the downconversion.
  • INPUT_FILTER_MAX_FREQUENCY: Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_FILTER_MIN_FREQUENCY: Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_IMPEDANCE: The input impedance of this channel. The units are Ohms.
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER: Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
  • SAMPLE_RATE: Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
  • SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE : Configures the duty cycle of the self trigger square wave signal. Behavior depends on the configuration of the SELF_TRIGGER_SQUARE_WAVE_SLOPE property (for example, if SELF_TRIGGER_SQUARE_WAVE_SLOPE is set to positive, the SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE attribute defines the percentage that the square wave is in the high state). Units are percentage of the period.
  • SELF_TRIGGER_SQUARE_WAVE_FREQUENCY : Specifies the frequency of the self-trigger square wave signal. The units are Hertz.
  • STREAM_SAMPLES_DATA_EMULATION_RATE: Specifies the emulated data rate in samples per seconds. Ignored if the Data Emulation is disabled.
  • TRIGGER_DELAY: Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
  • TRIGGER_HOLDOFF: Specifies the length of time in seconds the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform.
  • TRIGGER_HYSTERESIS: Specifies the trigger hysteresis in Volts.
  • TRIGGER_LEVEL: Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
  • TRIGGER_OUTPUT_OFFSET: Specifies the offset in Volts at the trigger output of the digitizer.
  • VERTICAL_OFFSET: The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
  • VERTICAL_RANGE: The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi String

Sets a String attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACTIVE_TRIGGER_SOURCE: Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability.
  • CONTROL_IO_SIGNAL: Signal present on a Control IO connector.
  • DDCCORE_DATA_SOURCE : Selects the input data source used by the DDC core (for example, "Channel1").
  • TIME_INTERLEAVED_CHANNEL_LIST: Use to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one or more channel names.
  • TRIGGER_OUTPUT_SOURCE: Select the trigger signal to drive the trigger output connector on the front panel.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Reference Oscillator

Contained in this section are VIs which are used to configure the reference oscillator.

Configure Reference Oscillator Output Enabled

Configure Reference Oscillator


AgMD2 : Configure Reference Oscillator Output Enabled

Configures whether or not the reference frequency signal appears at an output of the digitizer.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Output Enabled (Off)

Specifies whether or not the reference frequency signal appears at a reference output of the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Reference Oscillator

Configures the digitizer's reference oscillator.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Oscillator Source (Reference Oscillator Source Internal)

Specifies the source of the reference frequency signal. Defined values:

  • Internal (0) - The internal reference oscillator is used.
  • External (1) - An external reference oscillator is used.
  • AXIe Clk100 (4) - The AXIe backplane reference oscillator is used.

The driver uses this value to set the REFERENCE_OSCILLATOR_SOURCE attribute.

Oscillator Frequency

Specifies the frequency of the external reference oscillator. This parameter is only used if the Source is set to External. The driver uses this value to set the REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY attribute.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Sample Clock

Contained in this section are VIs related to sample clock.

Configure Sample Clock Output Enabled

Configure Sample Clock


AgMD2: Configure Sample Clock Output Enabled

Configures whether or not the sample clock appears at a reference output of the digitizer.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Enabled (Off)

Specifies whether or not the sample clock appears at a reference output of the digitizer. This value sets the SAMPLE_CLOCK_OUTPUT_ENABLED attribute.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Configure Sample Clock

Configures the digitizer's sample clock.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Source

Specifies the source of the sample clock signal. The driver uses this value to set the SAMPLE_CLOCK_SOURCE attribute.

Defined Values For Parameter Source :

  • SAMPLE_CLOCK_SOURCE_INTERNAL(0) : The internal sample clock is used.
  • SAMPLE_CLOCK_SOURCE_EXTERNAL(1) : An external sample clock is used.

Frequency

Specifies the frequency of the external sample clock. This parameter is only used if the Sample Clock Source property is set to External. The driver uses this value to set the External Sample Clock Frequency attribute.

Divider

Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source property is set to External.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


Self Trigger

Contained in this section are VIs related to self trigger.

Self Trigger Custom Wave Load Configuration File

Self Trigger Square Wave Configure


AgMD2: Self Trigger Custom Wave Load Configuration File

Loads the configuration for the self-trigger generator from a specified configuration file. Calling this VI will automatically set the self-trigger mode to Custom Wave.

Supported Models: U5303A, U5309A, U5310A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

TriggerSource

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single trigger source.

Path

Path to the self-trigger generator configuration file to load.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Remarks:

The customwave configuration file allows to define an arbitrary binary signal (containing just high and low values) which repeats itself at a certain frequency.

The signal is defined as a list of pulses (high value), each of them with an absolute start time inside the wave period, and a certain duration. These pulses cannot overlap each other, they must fit entirely within the signal period, and they must be defined sequentially in time. In addition, any of these pulses can generate a trigger on its rising edge. Only one trigger can be defined per signal.

The configuration file syntax is composed of [key = value] properties, with the possibility of defining nested subproperties. A property containing nested subproperties is called a metaproperty.

An example of a configuration customwave file with three pulses and the trigger generated at the first pulse is presented below:

Customwave file content example:

[CustomWave =

[Period = 100e-6]

[ShiftEnabled = 1]

[DataInverted = 0]

[Pulses =

[Pulse =

[Start = 0.0]

[Duration = 10e-6]

[IsTrigger = 1]]

[Pulse =

[Start = 20.0e-6]

[Duration = 10e-6]]

[Pulse =

[Start = 40.0e-6]

[Duration = 20e-6]]]]

Keywords explanation:

Keyword | Value type | Required | Description
CustomWave | Metaproperty | Mandatory | Holds a complete customwave definition
Period | Float64 | Mandatory | Customwave total period in seconds
ShiftEnabled | Boolean | Optional (default 1) | Flag to enable/disable the shifting algorithm for ADC synchronization for noise reduction. Useful for demo purposes
DataInverted | Boolean | Optional (default 0) | If this flag is enabled, all output values are inverted (high<->low)
Pulses | Metaproperty | Mandatory | Container for all defined pulses
Pulse | Metaproperty | Mandatory (at least one occurrence) | Container for a single pulse definition
Start | Float64 | Mandatory | Pulse absolute start time inside the period
Duration | Float64 | Mandatory | Pulse duration
IsTrigger | Boolean | Optional (default 0) | Flag to indicate that the pulse should generate a trigger. Although it is optional, one of the pulses should have this flag enabled


AgMD2: Self Trigger Square Wave Configure

Configures the square wave signal properties of the self-trigger generator. Calling this VI automatically sets the self-trigger mode to Square Wave.

Supported Models: U5303A, U5309A, U5310A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

TriggerSource

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single trigger source.

Frequency

Specifies the frequency of the self-trigger square wave signal. The units are Hertz. This value sets the Frequency property.

DutyCycle

Configures the duty cycle of the self trigger square wave signal. Behavior depends on the configuration of the Slope property (e.g. if Slope is set to positive, DutyCycle defines the percentage that the square wave is in the high state). Units are percentage of the period. This value sets the Duty Cycle property.

Slope (Trigger Slope Negative)

Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer. This value sets the Slope property.

Defined Values For Parameter Slope :

  • Trigger Slope Negative : A negative (falling) edge passing through the trigger level triggers the digitizer
  • Trigger Slope Positive : A positive (rising) edge passing through the trigger level triggers the digitizer.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


Trigger

Contained in this section are VIs related to triggers.

Configure Edge Trigger Source

Configure Pretrigger Samples

Configure Trigger Holdoff

Trigger Magnitude Configure


AgMD2 : Configure Edge Trigger Source

Sets the edge triggering properties. An edge trigger occurs when the trigger signal that you specify with the Source parameter passes through the voltage threshold that you specify with the level parameter and has the slope that you specify with the Slope parameter. This VI affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this VI. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this VI.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Source

Specifies the trigger source. This value sets the Trigger Source attribute.

Trigger Level

Specifies the trigger level. This value sets the TRIGGER_LEVEL attribute.

Trigger Slope (Trigger Slope Negative)

Specifies the trigger slope. This value sets the TRIGGER SLOPE attribute. The supported values are:

Name | Description
Negative (0) | A negative (falling) edge passing through the trigger level triggers the digitizer.
Positive (1) | A positive (rising) edge passing through the trigger level triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Pretrigger Samples

Specifies the number of samples that must be collected before a trigger event will be recognized.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Pretrigger Samples

The number of samples that must be collected before a trigger event will be recognized.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Trigger Holdoff

Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds.

Supported Models: M9203A, M9703B, M9709A, U5303A, U5309A, U5310A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Holdoff

The number of seconds the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Trigger Magnitude Configure

Sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition Mode = Downconverter and Trigger Type = Magnitude before calling this VI. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this VI.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

TriggerSource

The physical or virtual repeated capability identifier. Pass an empty string if the operation does not apply to a repeated capability. You can also pass an empty string if the device only has a single trigger source.

Level

Specifies the trigger level in Volts. This value sets the TRIGGER_LEVEL attribute.

Hysteresis

Specifies the trigger hysteresis in Volts. This value sets the TRIGGER_HYSTERESIS attribute.

Slope (Trigger Slope Negative)

Specifies the trigger slope. This value sets the TRIGGER_SLOPE attribute.

Negative (0) : A negative (falling) edge passing through the trigger level triggers the digitizer.

Positive (1) : A positive (rising) edge passing through the trigger level triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Remarks:

Re-triggering is prevented until the magnitude of the signal has met the following criteria:

  • If magnitude < Threshold - Hysteresis (when positive trigger slope is selected)
  • If magnitude > Threshold + Hysteresis (when negative trigger slope is selected)


AgMD2.lvlib: Baseline Correction Configure

Configures the baseline correction properties.

Supported Models: U5303A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

Mode (Disabled)

Defines the mode used during baseline correction accumulation. This value sets the Mode property.

Defined Values For Parameter Mode :

  • Disabled (0): Disables baseline correction.
  • Continuous (1): Selects continuous baseline correction mode. In this mode the data values for baseline correction are accumulated continuously, even during an acquisition.
  • Between Acquisitions (2): Selects between acquisitions mode. In this mode the data values for baseline correction are only accumulated between acquisitions.

ThresholdHigh

Defines the higher limit of the baseline range. Outside of this range, data values will be ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts. This value sets the ThresholdHigh attribute.

ThresholdLow

Defines the lower limit of the baseline range. Outside of this range, data values will be ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts. This value sets the ThresholdLow attribute.

DigitalOffset

Applies a digital offset after the baseline correction. This value sets the Digital Offset property

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2 : Configure Acquisition Record

Configures the most commonly configured properties of the digitizer acquisition subsystem. These properties are samples per record, number of records, and sample rate.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

NumRecordsToAcquire

Specifies the number of records in the acquisition. This value sets the NUM_RECORDS_TO_ACQUIRE attribute.

RecordSize

Specifies the number of samples in each record. This value sets the RECORD_SIZE attribute.

SampleRate

Specifies the sample rate in samples per second. This value sets the SAMPLE_RATE attribute.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Channel

Configures the most commonly configured properties of the digitizer channel subsystem. These properties are range, offset, coupling, probe attenuation, and whether the channel is enabled.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Enabled (Off)

Specifies if the channel is enabled for acquisition.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Vertical Range

Specifies the vertical range. This value sets the VERTICAL_RANGE attribute.

Vertical Offset

Specifies the vertical offset. This value sets the VERTICAL_OFFSET attribute.

Vertical Coupling (VerticalCouplingAC)

Specifies how to couple the input signal.This value sets the VERTICAL_COUPLING attribute. The supported values are:

Name | Description
AC (0) | The digitizer AC couples the input signal.
DC (1) | The digitizer DC couples the input signal.
GND (2) | The digitizer couples the channel to the ground.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Input Filter

Configures the minimum and maximum input filter frequencies for a specified channel.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Min Frequency

Specifies the minimum input filter frequency. This value sets the INPUT_FILTER_MIN_FREQUENCY attribute.

Max Frequency

Specifies the maximum input filter frequency. This value sets the INPUT_FILTER_MAX_FREQUENCY attribute.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Temperature Units

Configures the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Temperature Units (Temperature Units Celsius)

Temperature units to be used by the Board Temperature and Channel Temperature attributes. This value sets the TEMPERATURE_UNITS attribute. Supported values are:

Name | Description
Celsius (0) | Temperature values returned from the digitizer are in degrees Celsius.
Fahrenheit (1) | Temperature values returned from the digitizer are in degrees Fahrenheit.
Kelvin (2) | Temperature values returned from the digitizer are in degrees Kelvin.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Time Interleaved Channel List

Combines this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Channel List

A comma-separated list of one or more channel names to combine with the channel specified by Channel Name. This value sets the TIME_INTERLEAVED_CHANNEL_LIST attribute.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2: Logic Device Configure Buffer Addresses

Configures the indirect Buffer Addresses.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

BufferId

The firmware indirect buffer id. Only buffers 16 to 31 can be configured.

Base

The firmware indirect buffer base address.

Limit

The firmware indirect buffer limit address.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2 : Module Synchronization Configure Slaves

Configures the modules which are identified by their handles, as synchronized slaves of the current module (which becomes a master module).

Supported Models: M9703B, M9709A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

SlavesCount

Number of Slaves in the array.

Slaves

Array of slaves.

Numeric

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2: NSA Configure

Configures the Noise Suppressed Accumulation properties.

Supported Models: U5303A, U5309A, U5310A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

Enabled (Off)

Specifies whether the Noise Suppressed Accumulation is active. This value sets the NSA_ENABLED attribute.

Threshold

Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. The units are ADC counts. This value sets the NSA_THRESHOLD attribute.

NoiseBase

Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. The units are ADC counts. This value sets the NSA_NOISE_BASE attribute.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Peak Detection Configure

Configures the Peak Detection properties.

Supported Models: U5303A, U5309A, U5310A

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

AmplitudeAccumulationEnabled (Off)

Selects whether the amplitude value of the peak (in ADC counts) should be accumulated instead of the fixed value 1 during a peak detection. This value sets the PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED attribute.

RisingDelta

Defines the amount by which two consecutive samples must differ to be considered as rising edge in the peak detector algorithm. The units are ADC counts. This value sets the PEAK_DETECTION_RISING_DELTA attribute.

FallingDelta

Defines the amount by which two consecutive samples must differ to be considered as falling edge in the peak detector algorithm. The units are ADC counts. This value sets the PEAK_DETECTION_FALLING_DELTA attribute.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


Data VIs

Contained in this section are VIs which are used to collect data from the instrument.

Fetch

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Int8

Fetch Waveform Real64

Fetch Accumulated

Fetch Accumulated Waveform Int32

Fetch Accumulated Waveform Real 64

Fetch DDCCore

DDCCore Fetch Waveform Int16

DDCCore Fetch Waveform Int32

Fetch Multi-Record

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Real64

Logic Device

Logic Device Playback Stream Waveforms

Logic Device Read Indirect Int32

Logic Device Read Register Int32

Read

Read Waveform Int16

Read Waveform Int32

Read Waveform Int8

Read Waveform Real64

Module Synchronization Get Slaves

Stream Fetch Data Int32

User Control Read Control Register Int32


Fetch VIs

Contained in this section are VIs related to the fetch operations.

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Int8

Fetch Waveform Real64


AgMD2 : Fetch Waveform Int16

Returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = Scale Factor * data + Scale Offset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Waveform Int32

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = Scale Factor * data + Scale Offset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Waveform Int8

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = Scale Factor * data + Scale Offset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Waveform Real64

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Fetch Accumulated VIs

Contained in this section are VIs used to fetch accumulated waveforms.

Fetch Accumulated Waveform Int32

Fetch Accumulated Waveform Real 64


AgMD2: Fetch Accumulated Waveform Int32

Returns the accumulated waveform which the digitizer has acquired for the specified channel. This waveform is from a previously initiated accumulated acquisition in Averager or Peak Detection mode. Returned waveform data units are raw accumulated ADC values which may be converted to Volts by the formula: V = Scale Factor * data + Scale Offset.

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Channel Name

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArraySize

Number of elements in WaveformArray.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

ActualAverages

Indicates the number of accumulations actually performed during the acquisition.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Flags

Additional information flags associated to the waveform.

Numeric


AgMD2: Fetch Accumulated Waveform Real 64

Returns the accumulated waveform which the digitizer has acquired for the specified channel. This waveform is from a previously initiated accumulated acquisition in Averager or Peak Detection mode. Returned waveform data units are Volts.

Inputs

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Channel Name

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArraySize

Number of elements in WaveformArray.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

ActualAverages

Indicates the number of accumulations actually performed during the acquisition.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

Flags

Additional information flags associated to the waveform.

Numeric


Fetch VIs

Contained in this section are VIs related to the DDCCore fetch waveform operations.

DDCCore Fetch Waveform Int16

DDCCore Fetch Waveform Int32


AgMD2 : DDCCore Fetch Waveform Int16

Returns the (multi-record) waveform the digitizer acquired for the specified DDC core. The waveform is from a previously initiated acquisition. Returned waveform samples are complex values, stored as interleaved real and imaginary parts. They may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

WaveformArrayBufferSize

Number of elements in WaveformArray.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

DDCCore

The physical or virtual repeated capability identifier. Pass empty string if the operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

ScaleFactor

Scaling factor for the waveform data.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.
Numeric

Flags

Additional information flags associated to the waveform.
Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.
Numeric

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : DDCCore Fetch Waveform Int32

Returns the (multi-record) waveform the digitizer acquired for the specified DDC core. The waveform is from a previously initiated acquisition. Returned waveform samples are complex values, stored as interleaved real and imaginary parts. They may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

WaveformArrayBufferSize

Number of elements in WaveformArray.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

DDCCore

The physical or virtual repeated capability identifier. Pass empty string if the operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

ScaleFactor

Scaling factor for the waveform data.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.
Numeric

Flags

Additional information flags associated to the waveform.
Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.
Numeric

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Fetch Multi-Record VIs

Contained in this section are VIs used to fetch multi-record waveforms.

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Real64


AgMD2 : Fetch Multi-Record Waveform Int16

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int32

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int8

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Real64

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord (1)

Specifies the number of the first record to read.

NumRecords (1)

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Numeric

XIncrement

The time between points in the acquired waveform in seconds.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Logic Device VIs

Contained in this section are VIs related to Logic Device.

Logic Device Playback Stream Waveforms

Logic Device Read Indirect Int32

Logic Device Read Register Int32


AgMD2: Logic Device Playback Stream Waveforms

Starts playback of emulation data. The waveforms previously loaded (for example,through Logic Device Write Stream Waveform Int16 VI) will be started synchronously and played on all streams according to the stream mode.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..


AgMD2: Logic Device Read Indirect Int32

Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by Logic Device repeated capability into the memory referenced by Data.

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

Id

The firmware indirect buffer id.

StartAddress

The start address in the FPGA where the data will be read.

NumElements

Number of elements to read.

DataBufferSize

Number of elements in Data.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Data

Will contain the data read from the buffer. To accomodate hardware restrictions on addresses alignment, up to eight more elements may be needed to be able to actually transfer the total number of elements requested.

Numeric

ActualElements

Indicates how many elements were actually retrieved from the instrument.

FirstValidElement

Indicates the index of the first valid element in the output data array.


AgMD2: Logic Device Read Register Int32

Reads a 32 bits integer value from the register at Offset in the FPGA identified by Logic Device repeated capability.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A , U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single LogicDevice.

Offset

Address in the FPGA where the register will be read.

Outputs

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

Value

Will contain the value read from the register.


Read VIs

Contained in this section are VIs for read operations.

Read Waveform Int16

Read Waveform Int32

Read Waveform Int8

Read Waveform Real64


AgMD2 : Read Waveform Int16

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = Scale Factor * data + Scale Offset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Read Waveform Int32

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = Scale Factor * data + Scale Offset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Read Waveform Int8

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = Scale Factor * data + Scale Offset.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Read Waveform Real64

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

Waveform Array Size

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of Initial X Time Seconds and Initial X Time Fraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Stream Fetch Data Int32

This VI returns a stream of elements. The ElementSizeInBits and the meaning of each Element depend on the StreamType.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9710A, U5303A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Stream

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Nbr Elements To Fetch

Specifies the maximum number of elements to be retrieved from the instrument. Element size is 32 bits. Nbr Elements To Fetch must be an integer multiple of GranularityInBytes / 4 and it must not exceed MaxSizeInBytes / 4.

ArrayBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Array Actual Size

Actual number of elements in Array.

Available Elements

Indicates how many Elements were available to be retrieved from the instrument.

Array

Buffer into which the acquired data is stored. Buffer size must be sufficient to store at least NbrElementsToFetch Elements.
Numeric

Actual Elements

Indicates how many elements were actually retrieved from the instrument.

First Valid Element

Index of the first valid Element in the Array.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : User Control Read Control Register Int32

Reads the value of the UserControl register at given offset.

Supported Models: M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Offset

Offset in the User Control FPGA where the register will be read.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed..

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Value

Upon successful return, this parameter will contain the value read from the register.


Utility VIs

Contained in this section are VIs which are used to control various functions of the instrument.

Calibration

Calibration Cancel

Calibration Load From File

Calibration Save To File

Self Calibrate

Instrument Info

Instrument Info Attribute ID Value From String

Instrument Info Attribute ID Value To String

Disable

Error Message

Error-Query

Query Board Temperature

Query Channel Temperature

Query Min Waveform Memory

Reset

Reset With Defaults

Revision Query

Self-Test


Calibration VIs

Contained in this section are calibration-related VIs.

Calibration Cancel

Calibration Load From File

Calibration Save To File

Self Calibrate


AgMD2 : Calibration Cancel

Not Supported - Aborts any running self-calibration and returns.

Supported Models: None Supported

If a self-calibration is run from another thread, this other thread will be interrupted immediately and the call will return with an operation canceled error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Calibration Load From File

Loads calibration values and information from file.

Supported Models: M9203A, M9703B, U5303A, U5310A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Path

Path of the file from where the information will be loaded.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Calibration Save To File

Saves calibration values and information in a binary file.

Supported Models: M9203A, M9703B, U5303A, U5309A

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Path

Path of the binary file to which the information will be saved.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Self Calibrate

Executes all internal calibrations. If the digitizer does not support calibration, this VI silently succeeds.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Instrument Info

Contained in this section are VIs which are used to control general instrument information.

Instrument Info Attribute ID Value From String

Instrument Info Attribute ID Value To String


AgMD2 : Instrument Info Attribute ID Value From String

Converts the string representation of a property ID to its numeric value.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Str

String representation of the property ID, without the prefix 'PREFIX_ATTR_'.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Value

Numeric value of the property ID.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Remarks

The string representation of the attribute ID must be given without the prefix 'PREFIX_ATTR_'.

For example, "VERTICAL_RANGE" is the string representation of the attribute ID AGMD2_ATTR_VERTICAL_RANGE.


AgMD2 : Instrument Info Attribute ID Value To String

Converts a property ID into its string representation.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Value

Property ID value.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Str

String representation of the property ID , without the prefix 'PREFIX_ATTR_'.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Remarks

The string representation of the attribute ID is returned without the prefix 'PREFIX_ATTR_'.

For example, string representation of the attribute ID AGMD2_ATTR_VERTICAL_RANGE is returned as "VERTICAL_RANGE".


AgMD2 : Disable

Quickly places the instrument in a state where it has no or minimal effect on the external system to which it is connected. This state is not necessarily a known state.

Supported Models: All Supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Error Message

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the Error Message parameter.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Error Code

Instrument driver status code.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Error Message

Instrument driver error message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Error Query

Queries the instrument and returns instrument specific error information. This VI can be used when QUERY_INSTRUMENT_STATUS is True to retrieve error details when the driver detects an instrument error.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error code

Instrument error code.

error message

Instrument error message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Query Board Temperature

Queries the temperature of the entire board. The units are governed by the TEMPERATURE_UNITS attribute.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns the current temperature of the entire board. The units are governed by the TEMPERATURE_UNITS attribute.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Remarks:

The exact location of the temperature measurement is model dependent. Please refer to the table below for detailed information.

Model | Temperature Measurement
U5303A | DPU FPGA core temperature
U5309A | DPU FPGA core temperature


AgMD2 : Query Channel Temperature

Queries the temperature of a specific channel. The units are governed by the TEMPERATURE_UNITS attribute.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The name of the channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns the current temperature of the specified channel. The units are governed by the TEMPERATURE_UNITS attribute.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Remarks:

The exact location of the temperature measurement is model dependent. Please refer to the table below for detailed information.

Model | Temperature Measurement
U5303A | ADC core temperature
U5309A | ADC core temperature


AgMD2 : Query Min Waveform Memory

Determines the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Data Width

Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 8, 16, 32 or 64, corresponding to the intended Read/Fetch function.

Number of Records

Specifies the number of records that will be read.

Offset Within Record

Specifies the start index within the record from which the data should be retrieved.

Number of Points Per Record

Specifies the number of data points to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Number of Samples

The minimum buffer size in samples needed for a subsequent Read or Fetch call with the same readout parameters.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Reset

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers).

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Reset With Defaults

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

Supported Models: All supported

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Revision Query

Retrieves revision information from the instrument.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

instrument driver revision

Returns the revision of the IVI specific driver.

firmware revision

Returns the firmware revision of the instrument.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Self Test

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

Supported Models: All supported

This function actually performs an identical operation to the Self-Calibrate, but with the addition of an output message.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

self test result

The numeric result from the self test operation. 0 = no error (test passed)

self-test message

The self test status message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 Attributes

This section provides technical and programming support for using the Keysight AgMD2 LabVIEW API VIs to develop applications for your Digitizers.

The Attributes are values used by certain VIs to configure and return data about the state of the instrument.

ACQUISITION_DATA_LOCK

ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED

ACQUISITION_MODE

ACQUISITION_NUMBER_OF_AVERAGES

ACTIVE_TRIGGER_SOURCE

BASELINE_CORRECTION_DIGITAL_OFFSET

BASELINE_CORRECTION_MODE

BASELINE_CORRECTION_THRESHOLD_HIGH

BASELINE_CORRECTION_THRESHOLD_LOW

BOARD_TEMPERATURE

CALIBRATION_IS_REQUIRED

CHANNEL_CONNECTOR_NAME

CHANNEL_COUNT

CHANNEL_DATA_INVERSION_ENABLED

CHANNEL_ENABLED

CHANNEL_TEMPERATURE

CONTROL_IO_AVAILABLE_SIGNALS

CONTROL_IO_COUNT

CONTROL_IO_SIGNAL

CSR_ENABLED

CSR_STOP_MODE

DDCCORE_CENTER_FREQUENCY

DDCCORE_COUNT

DDCCORE_DATA_SOURCE

DDCCORE_DECIMATION_DENOMINATOR

DDCCORE_DECIMATION_NUMERATOR

DDCCORE_LO_INITIAL_PHASE

DELAY_CONTROL_COUNT

DELAY_CONTROL_ENABLED

DELAY_CONTROL_MAX

DELAY_CONTROL_MIN

DELAY_CONTROL_RANGE

DELAY_CONTROL_VALUE

DRIVER_SETUP

INPUT_CONNECTOR_SELECTION

INPUT_FILTER_BYPASS

INPUT_FILTER_MAX_FREQUENCY

INPUT_FILTER_MIN_FREQUENCY

INPUT_IMPEDANCE

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_INFO_CHASSIS_NUMBER

INSTRUMENT_INFO_IO_VERSION

INSTRUMENT_INFO_NBR_ADC_BITS

INSTRUMENT_INFO_OPTIONS

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_INFO_SLOT_NUMBER

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_FIXED_LATENCY_ENABLED

IO_RESOURCE_DESCRIPTOR

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_ARM

IS_WAITING_FOR_TRIGGER

LOGIC_DEVICE_COUNT

LOGIC_DEVICE_FIRMWARE_STORE_COUNT

LOGIC_DEVICE_IFDL_COUNT

LOGIC_DEVICE_IFDL_ENABLED

LOGIC_DEVICE_IFDL_IS_ACTIVE

LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL

LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE

LOGIC_DEVICE_MEMORY_BANK_COUNT

LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED

LOGIC_DEVICE_SAMPLES_UNSIGNED

LOGIC_DEVICE_STREAM_MODE

LOGIC_DEVICE_STREAMS_COUNT

LOGICAL_NAME

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MIN_RECORD_SIZE

MODULE_SYNCHRONIZATION_HANDLE

MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE

MONITORING_VALUE_COUNT

MONITORING_VALUE_CURRENT_VALUE

MONITORING_VALUE_LIMIT_HIGH

MONITORING_VALUE_LIMIT_LOW

MONITORING_VALUE_UNIT

NSA_ENABLED

NSA_NOISE_BASE

NSA_THRESHOLD

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED

PEAK_DETECTION_FALLING_DELTA

PEAK_DETECTION_RISING_DELTA

QUERY_INSTRUMENT_STATUS

RECORD_SIZE

REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

REFERENCE_OSCILLATOR_OUTPUT_ENABLED

REFERENCE_OSCILLATOR_SOURCE

SAMPLE_CLOCK_EXTERNAL_DIVIDER

SAMPLE_CLOCK_EXTERNAL_FREQUENCY

SAMPLE_CLOCK_OUTPUT_ENABLED

SAMPLE_CLOCK_SOURCE

SAMPLE_RATE

SELF_TRIGGER_MODE

SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE

SELF_TRIGGER_SQUARE_WAVE_FREQUENCY

SELF_TRIGGER_SQUARE_WAVE_SLOPE

SIMULATE

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

STREAM_COUNT

STREAM_ENABLED

STREAM_GRANULARITY_IN_BYTES

STREAM_MARKERS_BITS_PER_MARKER

STREAM_MARKERS_FRACTIONAL_BITS

STREAM_MAX_SIZE_IN_BYTES

STREAM_MINMAX_FRAME_SIZE

STREAM_SAMPLES_BITS_PER_SAMPLE

STREAM_SAMPLES_DATA_EMULATION_ENABLED

STREAM_SAMPLES_DATA_EMULATION_RATE

STREAM_SAMPLES_DATA_TRUNCATION_BIT_COUNT

STREAM_SAMPLES_DATA_TRUNCATION_ENABLED

STREAM_SAMPLES_DATA_TRUNCATION_KEEP_MSB

STREAM_TYPE

SUPPORTED_INSTRUMENT_MODELS

TEMPERATURE_UNITS

TIME_INTERLEAVED_CHANNEL_LIST

TIME_INTERLEAVED_CHANNEL_LIST_AUTO

TRIGGER_COUPLING

TRIGGER_DELAY

TRIGGER_HOLDOFF

TRIGGER_HYSTERESIS

TRIGGER_LEVEL

TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES

TRIGGER_MAGNITUDE_SLOPE

TRIGGER_OUTPUT_ENABLED

TRIGGER_OUTPUT_OFFSET

TRIGGER_OUTPUT_SOURCE

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_OPERATOR

TRIGGER_TYPE

TSR_ENABLED

TSR_IS_ACQUISITION_COMPLETE

TSR_MEMORY_OVERFLOW_OCCURRED

USER_CONTROL_COUNTERS_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

USER_CONTROL_POST_TRIGGER

USER_CONTROL_PRE_TRIGGER

USER_CONTROL_START_ON_TRIGGER_ENABLED

USER_CONTROL_TRIGGER_ENABLE_SOURCE

USER_CONTROL_TRIGGER_FACTOR

USER_CONTROL_TRIGGER_SELECTION

VERTICAL_COUPLING

VERTICAL_OFFSET

VERTICAL_RANGE


ACQUISITION_DATA_LOCK

Reports the Data Lock state.

Data Type

Integer32, Read-Only
Supported Values
0 | DATA_LOCK_UNLOCKED | Normal operation.
1 | DATA_LOCK_ARMED | State will become Locked at the next Acquisition start.
2 | DATA_LOCK_LOCKED | Acquired data are locked. Only Fetch operations are allowed.
Supported Model

M9703B


ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED

Not Supported - Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.

Data Type

Boolean
Supported Values

True

False


ACQUISITION_MODE

The acquisition mode.

Data Type

Integer32
Supported Values
0 | NORMAL | Normal digitizer mode.
1 | AVERAGER | Averager mode.
2 | PEAK_DETECTION | Peak detection mode.
3 | BASE_BAND0 | Base Band 0 mode.
4 | DIGITAL_DOWN_CONVERSION |
15 | USER_FDK | User FDK mode.
Supported Models

All Supported


ACQUISITION_NUMBER_OF_AVERAGES

Specifies the number of waveforms to average in the record. This attribute affects instrument behavior only when the ACQUISITION MODE attribute is set to AVERAGER or PEAK_DETECTION.

Data Type

Integer32
Supported Models

U5303A, U5309A, U5310A


ACTIVE_TRIGGER_SOURCE

Specifies the source the digitizer monitors for the trigger event.

Data Type

String
Notes

The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability
Supported Models

All supported

Remarks

WARNING: Immediate trigger source is not supported for multi-record acquisitions.


BASELINE_CORRECTION_DIGITAL_OFFSET

Applies a digital offset after the baseline correction.

Data Type

Integer32
Supported Models

U5303A


BASELINE_CORRECTION_MODE

Defines the mode used during baseline correction accumulation.

Data Type

Integer32
Supported Values
0 | Disabled | Disables baseline correction.
1 | Continuous | The data values for baseline correction are accumulated continuously, even during an acquisition.
2 | Between Acquisitions | The data values for baseline correction are only accumulated between acquisitions.
Supported Models

U5303A


BASELINE_CORRECTION_THRESHOLD_HIGH

Defines the higher limit of the baseline range. Outside of this range, data values are ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts.

Data Type

Integer32
Supported Models

U5303A


BASELINE_CORRECTION_THRESHOLD_LOW

Defines the lower limit of the baseline range. Outside of this range, data values are ignored. This is an absolute value (from 0 to vertical range). The units are ADC counts.

Data Type

Integer32
Supported Models

U5303A


BOARD_TEMPERATURE

Indicates the temperature of the entire board.

Data Type

Real64, Read-Only
Notes

The units are governed by the TEMPERATURE_UNITS attribute. The exact location of the temperature measurement is model dependent. Refer to the Query Board Temperature VI for detailed information.
Supported Models

All Supported


CALIBRATION_IS_REQUIRED

Returns whether or not a self calibration is required.

Data Type

Boolean, Read-Only
Supported Values
True | A self calibration is required.
False | A self calibration is not required.
Supported Models

All Supported


CHANNEL_CONNECTOR_NAME

The connector name as it appears on the instrument's front panel.

Data Type

String, Read-Only
Supported Models

All Supported


CHANNEL_COUNT

The number of channels present on the instrument.

Data Type

Integer32, Read-Only
Supported Models

All Supported


CHANNEL_DATA_INVERSION_ENABLED

Specifies whether the data acquired is inverted.

Data Type

Boolean
Supported Values
True | The data acquired is inverted.
False | The data acquired is not inverted.
Supported Models

U5303A, U5309A, U5310A


CHANNEL_ENABLED

Specifies whether the digitizer acquires a waveform for the channel.

Data Type

Boolean
Supported Values
True | A waveform is acquired for the selected channel.
False | A waveform is not acquired for the selected channel.
Supported Models

All Supported


CHANNEL_TEMPERATURE

Indicates the temperature of the channel.

Data Type

Real64, Read-Only
Notes

The units are governed by the TEMPERATURE_UNITS attribute. he exact location of the temperature measurement is model dependent. Refer to the Query Channel Temperature VI for detailed information.
Supported Models

All Supported


CONTROL_IO_AVAILABLE_SIGNALS

Comma separated list of available signal names that can be used for the Signal attribute of this repeated capability.

Data Type

String, Read-Only
Supported Models

All Supported


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > CONTROL_IO_COUNT

CONTROL_IO_COUNT

The number of Control IO Connectors.

Data Type

Integer32, Read-Only


CONTROL_IO_SIGNAL

Signal present on a Control IO connector.

Data Type

String, Read-Only
Notes

Setting of a signal value does not immediately apply the change to the instrument. In order for the change to be effective, Apply Setup must be called.

This behavior is consistent for all settings changes. Note that some actions do perform an implicit Apply Setup.

Supported Models

All Supported


CSR_ENABLED

Specifies whether the CSR mode is enabled on the instrument.

Data Type

Boolean
Supported Values
True | CSR mode is enabled on the instrument.
False | CSR mode is not enabled on the instrument.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


CSR_STOP_MODE

Specifies the CSR acquisition stop mode.

Data Type

Integer32
Supported Values

0

Continuous

The CSR acquisition stops only on internal buffer overflow.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


DDCCORE_CENTER_FREQUENCY

Specifies the center frequency from which the digitizer will downconvert. It sets the local oscillator frequency.

The units are Hertz.

Data Type

Real64
Supported Model

M9703B


DDCCORE_COUNT

Specifies the number of DDC cores.

Data Type

Integer32, Read-Only
Supported Models

All supported


DDCCORE_DATA_SOURCE

Selects the input data source used by the DDC core (for example,."Channel1").

Data Type

String
Supported Model

M9703B


DDCCORE_DECIMATION_DENOMINATOR

The denominator of the fractional decimation factor. The decimation factor is applied to the data source sample rate to determine the decimated rate used by the DDC core.

Data Type

Integer64

Supported Model

M9703B


DDCCORE_DECIMATION_NUMERATOR

The numerator of the fractional decimation factor. The decimation factor is applied to the data source sample rate to determine the decimated rate used by the DDC core.

Data Type

Integer64

Supported Model

M9703B


DDCCORE_LO_INITIAL_PHASE

The initial phase of the local oscillator the DDC core will use during the downconversion.

Data Type

Real64
Supported Model

M9703B


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > DELAY_CONTROL_COUNT

DELAY_CONTROL_COUNT

The number of delay controls available.

Data Type

Integer32, Read-Only


DELAY_CONTROL_ENABLED

Not Supported - Specifies whether the delay controls are set manually.

Data Type

Boolean
Supported Values
True | All delay controls must be set manually.
False | The delay controls are set by the self-calibration.

Supported Models

None Supported


DELAY_CONTROL_MAX

Not Supported - Maximum value (DAC code) that can be set for the delay control.

Data Type

Integer32, Read-Only

Supported Models

None supported


DELAY_CONTROL_MIN

Not Supported - Minimum value (DAC code) that can be set for the delay control.

Data Type

Integer32, Read-Only

Supported Models

None supported


DELAY_CONTROL_RANGE

Not Supported - Selects the range for the delay control. Useful only for delay controls with multiple ranges.

Data Type

Integer32, Read-Only
Supported Values
0 | Default
1 | Extended

Supported Models

None supported


DELAY_CONTROL_VALUE

Not Supported - The value (DAC code) set for the delay control.

Data Type

Integer32

Supported Models

None supported

Remarks

WARNING: These controls are provided for very specific use cases. Their usage may have significant influences on the analog performance of the digitizer.

The delay controls are in DAC codes or delay steps, but not in time unit because the DACs are not calibrated. The conversion factors to time are provided for guidance but should not be taken as exact or calibrated values. If exact times are required, an external calibration is necessary.

Delay control repeated capability supported values

Repcap name | Description | Min | Max | Time Step or Delay [ps] | Time Range [ps]
DelayAXIe100 | Controls the delay on the AXIe 100MHz reference. | 0 | 4095 | ~0.130 | 0 to ~550 (Not linear)
DelayPLLReference | Controls the delay on the PLL reference. Positive values will control the delay of the AXIe and External references. Negative values will control the delay of the Internal reference, and in the opposite direction (i.e. negative delay values). | -7 | 7 | Not linear: 0: 0 1: 160 2: 320 3: 480 4: 830 5: 1130 6: 1450 7: 1750 -1750 to 1750 |
DelaySampleClock<X> | Control the delay on the Sample Clock for channels on DPU <X>. <X> can be A, B, C or D (e.g. DelaySampleClockA). There is an Extended range which can be selected with the Range property. | 0 | 4095 | ~0.007 (Default range) ~0.013 (Extended range) | 0 to ~30 (Default range) 0 to ~60 (Extended range)

Note

Time Step and Time Range are specific to the hardware and can be different for each instrument modules. The values here are approximate.


DRIVER_SETUP

The driver setup string.

It is either specified in the Configuration Store or passed in the Option String parameter of the Initialize With Options VI.

Data Type

String, Read-Only
Notes

Driver setup is empty if the driver is not initialized.
Supported Models

All supported


INPUT_CONNECTOR_SELECTION

Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, then the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.

Data Type

Integer32
Supported Values
1 | Connector 1 is used.
2 | Connector 2 is used.
Supported Models

All supported


INPUT_FILTER_BYPASS

Specifies whether or not to bypass the input filter.

Data Type

Boolean
Supported Values
True | The input filter is bypassed.
False | The input filter is used.
Supported Models

All supported


INPUT_FILTER_MAX_FREQUENCY

Specifies the maximum input filter frequency.

The units are Hertz.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed.
Supported Models

All supported


INPUT_FILTER_MIN_FREQUENCY

Specifies the minimum input filter frequency.

The units are Hertz.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Supported Models

All supported


INPUT_IMPEDANCE

The input impedance of the channel. The units are Ohms.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, refer to the specific instrument user guide for information.
Supported Models

All supported


INSTRUMENT_FIRMWARE_REVISION

The firmware revision reported by the physical instrument.

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Supported Models

All supported


INSTRUMENT_INFO_CHASSIS_NUMBER

Chassis number.

Data Type

Integer32, Read-Only
Supported Models

M9205A, M9206A, M9703A, M9710A


INSTRUMENT_INFO_IO_VERSION

Version of the IO Driver used by this module.

Data Type

String, Read-Only
Supported Models

All supported


INSTRUMENT_INFO_NBR_ADC_BITS

Number of bits of data per sample from this module's ADCs.

Data Type

Unsigned Integer32, Read-Only
Supported Models

All supported


INSTRUMENT_INFO_OPTIONS

List of comma separated options installed in this instrument.

Data Type

String, Read-Only
Supported Models

All supported


INSTRUMENT_INFO_SERIAL_NUMBER_STRING

The serial number string of the instrument.

Data Type

String Read-Only
Supported Models

All supported


INSTRUMENT_INFO_SLOT_NUMBER

Slot number of the instrument in the chassis.

Data Type

Integer32, Read-Only

Supported Models

M9203A, M9205A, M9206A, M9703B, M9709A


INSTRUMENT_MANUFACTURER

The name of the manufacturer reported by the physical instrument.

Manufacturer is limited to 256 bytes.

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition.
Supported Models

All supported


INSTRUMENT_MODEL

The model number or name reported by the physical instrument.

Model is limited to 256 bytes.

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition.
Supported Models

All supported


IO_FIXED_LATENCY_ENABLED

Specifies whether the IO input is propagated to the DPUs with potentially variable latency or with guaranteed fixed latency.

Data Type

Boolean
Supported Values

True

False

Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


IO_RESOURCE_DESCRIPTOR

The resource descriptor specifies the connection to a physical device.

It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function.

Data Type

String, Read-Only
Notes

It is empty if the driver is not initialized.
Supported Models

All supported


IS_IDLE

Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Integer32, Read-Only
Supported Values
1 | Instrument is in the Idle state.
2 | Instrument in not in the Idle state.
3 | The state of the instrument is unknown.
Supported Models

All supported


IS_MEASURING

Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Integer32, Read-Only
Supported Values
1 | The instrument is currently in the Measuring state.
2 | The instrument is not in the Measuring state.
3 | The driver cannot query the instrument to determine if the digitizer is in the Measuring state.
Supported Models

All supported


IS_WAITING_FOR_ARM

Not Supported - Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Integer32, Read-Only
Supported Values
1 | The instrument is currently Waiting for Arm.
2 | The instrument is not Waiting for Arm.
3 | The driver cannot query the instrument to determine if the digitizer is Waiting for Arm.
Supported Models

All supported


IS_WAITING_FOR_TRIGGER

Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Integer32, Read-Only
Supported Values
1 | The instrument is currently waiting for a trigger event.
2 | The instrument is not waiting for a trigger.
3 | The driver cannot query the instrument to determine if the digitizer is Waiting for trigger event.
Supported Models

All supported


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_COUNT

LOGIC_DEVICE_COUNT

Returns the number of logic devices.

Data Type

Integer32, Read-Only


LOGIC_DEVICE_FIRMWARE_STORE_COUNT

Number of available firmware stores in the LogicDevice.

Data Type

Integer32, Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_IFDL_COUNT

LOGIC_DEVICE_IFDL_COUNT

Returns the number of LogicDevice IFDLs.

Data Type

Integer32, Read-Only


LOGIC_DEVICE_IFDL_ENABLED

Specifies whether the IFDL is enabled.

Data Type

Boolean
Supported Values
True | The IFDL is enabled.
False | The IFDL is not enabled.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A


LOGIC_DEVICE_IFDL_IS_ACTIVE

Returns whether the IFDL is currently active.

Data Type

Boolean, Read Only
Supported Values
True | The IFDL is active.
False | The IFDL is not active.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A


LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL

Specifies how the MemoryBank accesses are controlled. This value is used only when the ACQUISITION_MODE is USER_FDK.

Data Type

Integer32, Read-Only
Supported Values
0 | SOFTWARE | Software control of LogicDevice MemoryBank. In this mode, the value of LogicDevice Memory Access Mode indicates whether the memory is used for reading or writing.
1 | FIRMWARE | Custom control of LogicDevice MemoryBank from the User Firmware. In this mode, the User Firmware controls accesses to the memory, and the value of LogicDevice Memory Access Mode is ignored.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A, U5303A, U5307A, U5309A


LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE

When MemoryBank access is controlled by software, specifies how the memory is currently accessed.

Data Type

Integer32, Read-Only
Supported Values
0 | WRITE | Under Software LogicDevice MemoryBank Access Control, this value indicates that the memory is currently used for Writing.
1 | READ | Under Software LogicDevice MemoryBank Access Control, this value indicates that the memory is currently used for Reading.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A, U5303A, U5307A, U5309A


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_MEMORY_BANK_COUNT

LOGIC_DEVICE_MEMORY_BANK_COUNT

Number of memory banks in LogicDevice.

Data Type

Integer32, Read-Only


LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED

Enables the FIFO mode for MemoryBank. Used when streaming.

Data Type

Boolean
Supported Values
True | The FIFO mode is enabled for MemoryBank.
False | The FIFO mode is not enabled for MemoryBank.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A, U5303A, U5307A, U5309A


LOGIC_DEVICE_SAMPLES_UNSIGNED

When True, directs the LogicDevice to receive unsigned samples values from the ADC.

Data Type

Boolean
Supported Values
True | Directs the LogicDevice to receive unsigned samples values from the ADC.
False | Does not direct the LogicDevice to receive unsigned samples values from the ADC.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9709A, M9710A, U5303A, U5307A, U5309A


LOGIC_DEVICE_STREAM_MODE

Specifies the mode the Streams are operating in.

Data Type

Integer32, Read-Only
Supported Values
0 | ACQUISITION | In Acquisition mode, the LogicDevice receives actual values from the ADC. This is the default mode.
1 | EMULATION | In Emulation mode, the LogicDevice receives the values that have been uploaded to each stream using WriteStreamWaveformInt16().
2 | SEQUENTIAL |
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


LOGIC_DEVICE_STREAMS_COUNT

Number of Streams available in the LogicDevice.

Data Type

Integer32, Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


LOGICAL_NAME

Logical Name identifies a driver session in the Configuration Store.

Data Type

String, Read-Only
Notes

If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
Supported Models

All supported


MAX_FIRST_VALID_POINT_VAL

Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieve the entire acquisition.

Data Type

Integer64
Supported Models

All supported


MAX_SAMPLES_PER_CHANNEL

Returns the maximum number of samples per channel that can be captured.

Data Type

Integer64, Read-Only
Supported Models

All supported


MIN_RECORD_SIZE

Indicates the minimum waveform record size.

Data Type

Integer64, Read-Only
Notes

If the digitizer can support any arbitrary size record, then this attribute returns 1.
Supported Models

All supported


MODULE_SYNCHRONIZATION_HANDLE

The handle of the current module.

Data Type

Integer32, Read-Only
Supported Models

M9703B, M9709A


MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE

The handle of the master module, when synchronized. This value will be identical to the attribute Handle if this module is the master, and equal to 0 when not synchronized.

Data Type

Integer32, Read-Only
Supported Models

M9703B, M9709A


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > MONITORING_VALUE_COUNT

MONITORING_VALUE_COUNT

Returns the number of MonitoringValues.

Data Type

Integer32, Read-Only


MONITORING_VALUE_CURRENT_VALUE

Returns the current monitored value of the MonitoringValue.

Data Type

Real64, Read-Only
Supported Models

All supported


MONITORING_VALUE_LIMIT_HIGH

Returns the limit value above which the instrument behavior may not be consistent with the specifications.

Data Type

Real64, Read-Only
Supported Models

All supported


MONITORING_VALUE_LIMIT_LOW

Returns the limit value below which the instrument behavior may not be consistent with the specifications.

Data Type

Real64, Read-Only
Supported Models

All supported


MONITORING_VALUE_UNIT

Returns the unit of this monitoring value.

Data Type

String, Read-Only
Supported Models

All supported


NSA_ENABLED

Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the ACQUISITION_MODE attribute is set to Averager.

Data Type

Boolean
Supported Values
True | Noise Suppressed Accumulation is active.
False | Noise Suppressed Accumulation is not active.
Supported Models

U5303A, U5309A, U5310A


NSA_NOISE_BASE

Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. The units are ADC counts.

Data Type

Integer32
Supported Models

U5303A, U5309A, U5310A


NSA_THRESHOLD

Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. The units are ADC counts.

Data Type

Integer32
Supported Models

U5303A, U5309A, U5310A


NUM_ACQUIRED_RECORDS

Gets the total number of records acquired since the acquisition was last initiated.

Data Type

Integer64, Read-Only
Notes

You may check this value while an acquisition is in progress.
Supported Models

All supported


NUM_RECORDS_TO_ACQUIRE

Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

Data Type

Integer64
Supported Models

All supported


PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED

Specifies whether the amplitude value of the peak (in ADC counts) should be accumulated instead of a fixed value of 1 for a detected peak.

Data Type

Boolean
Supported Values
True | The amplitude value of the peak is accumulated.
False | The amplitude value of the peak is not accumulated.
Supported Models

U5303A, U5309A, U5310A


PEAK_DETECTION_FALLING_DELTA

Defines the amount by which two consecutive samples must differ to be considered as falling edge in the peak detector algorithm. The units are ADC counts.

Data Type

Integer32
Supported Models

U5303A, U5309A, U5310A


PEAK_DETECTION_RISING_DELTA

Defines the amount by which two consecutive samples must differ to be considered as rising edge in the peak detector algorithm. The units are ADC counts.

Data Type

Integer32
Supported Models

U5303A, U5309A, U5310A


QUERY_INSTRUMENT_STATUS

If True, the driver queries the instrument status at the end of each VI that performs I/O to the instrument. If an error is reported, use Error Query to retrieve error messages, one at a time, from the instrument.

Data Type

Boolean
Supported Values
True | The driver queries the instrument status at the end of each VI that performs I/O to the instrument.
False | The driver does not query the instrument status at the end of each VI that performs I/O to the instrument.
Supported Models

All supported


RECORD_SIZE

Specifies the number of samples to acquire in each waveform record.

Data Type

Integer64
Supported Models

All supported


REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

Specifies the frequency of the external signal which is used as a frequency reference.

The units are Hertz.

Data Type

Real64
Notes

This value is used only if the Reference Oscillator Source attribute is set to External.
Supported Models

All supported


REFERENCE_OSCILLATOR_OUTPUT_ENABLED

Specifies whether or not the reference frequency signal appears at an output of the digitizer.

Data Type

Boolean
Supported Values
True | The reference oscillator output signal is enabled.
False | The reference oscillator output is disabled.
Supported Models

All supported


REFERENCE_OSCILLATOR_SOURCE

Specifies the reference frequency source used.

Data Type

Integer32
Supported Values
0 | The internal reference oscillator is used.
1 | An external reference oscillator is used.
4 | AXIe 100 MHz reference clock is used.

The validity of these values is model dependent, please check the capability of your particular model.

Supported Models

All supported


SAMPLE_CLOCK_EXTERNAL_DIVIDER

Specifies the value by which the external sample clock should be divided.

Data Type

Real64
Notes

This value is used only if the Sample Clock Source attribute is set to External.
Supported Models

All supported


SAMPLE_CLOCK_EXTERNAL_FREQUENCY

Specifies the frequency of the external signal which is used as a sample clock.

The units are Hertz.

Data Type

Real64
Notes

This value is used only if the SAMPLE_CLOCK_SOURCE attribute is set to External.
Supported Models

All supported


SAMPLE_CLOCK_OUTPUT_ENABLED

Specifies whether or not the sample clock appears at a reference output of the digitizer.

Data Type

Boolean
Supported Values
True | The sample clock appears at a reference output of the digitizer.
False | The sample clock does not appear at a reference output of the digitizer.
Supported Models

All supported


SAMPLE_CLOCK_SOURCE

Specifies the clock used to pace acquisition sampling.

Data Type

Integer32
Supported Values
0 | The internal sample clock is used.
1 | An external sample clock is used.
Supported Models

All supported


SAMPLE_RATE

Specifies the rate of the sample clock in samples per second.

This number represents the inverse of the interval between samples in the acquisition record.

Data Type

Real64
Supported Models

All supported


SELF_TRIGGER_MODE

Defines the self-trigger signal generation mode.

Data Type

Integer32
Supported Values
0 | Custom Wave
1 | Square Wave
Supported Models

U5303A, U5309A, U5310A


SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE

Configures the duty cycle of the self trigger square wave signal. Behavior depends on the configuration of the SELF_TRIGGER_SQUARE_WAVE_SLOPE property (for example, if SELF_TRIGGER_SQUARE_WAVE_SLOPE is set to positive, the SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE attribute defines the percentage that the square wave is in the high state). Units are percentage of the period.

Data Type

Real64
Supported Models

U5303A, U5309A, U5310A


SELF_TRIGGER_SQUARE_WAVE_FREQUENCY

Specifies the frequency of the self-trigger square wave signal. The units are Hertz.

Data Type

Real64
Supported Models

U5303A, U5309A, U5310A


SELF_TRIGGER_SQUARE_WAVE_SLOPE

Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer.

Data Type

Integer32
Supported Values
0 | Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
1 | Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.
Supported Models

U5303A, U5309A, U5310A


SIMULATE

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Data Type

Boolean
Supported Values
True | The instrument simulates values for output parameters.
False | The instrument operates normally.
Supported Models

All supported


SPECIFIC_DRIVER_DESCRIPTION

Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SPECIFIC_DRIVER_REVISION

Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SPECIFIC_DRIVER_VENDOR

Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


STREAM_COUNT

Returns the number of streams.

Data Type

Integer32 Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_ENABLED

Specifies whether the stream is enabled on the instrument.

Data Type

Boolean
Supported Values
True | The stream is enabled on the instrument.
False | The stream is not enabled on the instrument.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_GRANULARITY_IN_BYTES

Indicates the granularity of data for the FetchData operations.

Data Type

Integer64, Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_MARKERS_BITS_PER_MARKER

Number of bits representing a Marker value.

Data Type

Integer32, Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_MARKERS_FRACTIONAL_BITS

Number of fractional bits in the Marker value.

Data Type

Integer32, Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_MAX_SIZE_IN_BYTES

Indicates the maximal size of data for the FetchData operations.

Data Type

Integer64, Read-Only
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_MINMAX_FRAME_SIZE

Number of samples over which each MinMax pair is computed.

Data Type

Integer64
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A


STREAM_SAMPLES_BITS_PER_SAMPLE

Returns the number of bits per sample.

Data Type

Integer32, Read-Only

Remarks

If Data Truncation is disabled, the value of this attribute is equal to 16 and the most significant bits of each sample contain a raw digitizer data sample.

If Data Truncation is enabled, the value of this attribute is equal to the value of STREAM_SAMPLES_DATA_TRUNCATION_BIT_COUNT.

The sample contains the most significant bits or the least significant bits of a raw digitizer data sample, depending on the value of STREAM_SAMPLES_DATA_TRUNCATION_KEEP_MSB.

Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_SAMPLES_DATA_EMULATION_ENABLED

Specifies whether the Data Emulation is enabled.

Data Type

Boolean
Supported Values
True | The output data is fetched from an internal ramp waveform generator.
False | The output data is fetched from the digitizer ADC stream.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_SAMPLES_DATA_EMULATION_RATE

Specifies the emulated data rate in samples per seconds. Ignored if the Data Emulation is disabled.

Data Type

Real64
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_SAMPLES_DATA_TRUNCATION_BIT_COUNT

Specifies the size in bits of an output stream element. Ignored if STREAM_SAMPLES_DATA_TRUNCATION_ENABLED is False.

Data Type

Integer32
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_SAMPLES_DATA_TRUNCATION_ENABLED

Specifies whether the Data Truncation is enabled.

Data Type

Boolean
Supported Values
True | Data truncation is enabled.
False | Data truncation is not enabled.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_SAMPLES_DATA_TRUNCATION_KEEP_MSB

Specifies whether the output stream element contains the most significant or the least significant bits of the raw digitizer data sample. Ignored if STREAM_SAMPLES_DATA_TRUNCATION_ENABLED is False.

Data Type

Boolean
Supported Values

True

False

Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


STREAM_TYPE

Indicates the type of the stream.

Data Type

Integer32, Read-Only
Supported Values
0 | Markers | A stream of this type provides time markers related to acquired or emulated samples.
1 | Minmax | A stream of this type provides minmax pairs computed over a frame of acquired or emulated samples.
2 | Samples | A stream of this type provides acquired or emulated data samples.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9710A, U5303A


SUPPORTED_INSTRUMENT_MODELS

A comma-separated list of instrument models that the IVI specific driver can control.

Data Type

String, Read-Only
Notes

The string does not include an abbreviation for the manufacturer if it is the same for all models.
Supported Models

All supported


TEMPERATURE_UNITS

Specifies the temperature units returned by the BOARD_TEMPERATURE and the CHANNEL_TEMPERATURE attributes.

Data Type

Integer32
Supported Values
0 | Celcius | Temperature values returned from the digitizer are in degrees Celsius.
1 | Fahrenheit | Temperature values returned from the digitizer are in degrees Fahrenheit.
2 | Kelvin | Temperature values returned from the digitizer are in degrees Kelvin.
Supported Models

All supported


TIME_INTERLEAVED_CHANNEL_LIST

This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.

Data Type

String
Supported Models

All supported


TIME_INTERLEAVED_CHANNEL_LIST_AUTO

Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates.

Data Type

Boolean
Supported Values
True | The instrument automatically combines channels to meet the sample rate requirements specified via the Sample Rate attribute.
False | The instrument does not automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
Supported Models

All supported


TRIGGER_COUPLING

Specifies how the digitizer couples the trigger source.

Data Type

Integer32
Supported Values
0 | AC | The digitizer AC couples the trigger signal.
1 | DC | The digitizer DC couples the trigger signal.
2 | HF Reject | The digitizer filters out the high frequencies from the arm signal.
3 | LF Reject | The digitizer filters out the low frequencies from the arm signal.
4 | Noise Reject | The digitizer filters out the noise from the arm signal.
Supported Models

All supported


TRIGGER_DELAY

Specifies the length of time from the trigger event to the first point in the waveform record.

The units are seconds.

Data Type

Real64
Supported Values
negative | Pre-Trigger | If the value is negative, the first point in the waveform record occurs before the trigger event.
positive | Post-Trigger | If the value is positive, the first point in the waveform record occurs after the trigger event
Supported Models

All supported


TRIGGER_HOLDOFF

Specifies the length of time in seconds the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are both non-zero, then both conditions must be satisfied before the digitizer accepts a trigger.

Data Type

Real64
Supported Models

M9203A, M9703B, M9709A, U5303A, U5309A, U5310A


TRIGGER_HYSTERESIS

Specifies the trigger hysteresis in Volts.

Data Type

Real64
Supported Models

All supported


TRIGGER_LEVEL

Specifies the voltage threshold for the trigger sub-system.

The units are Volts.

Data Type

Real64
Notes

This attribute affects instrument behavior only when the TRIGGER_TYPE is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger.

This attribute, along with the TRIGGER_SLOPE, ACTIVE_TRIGGER_SOURCE, and TRIGGER_COUPLING attributes, defines the trigger event when the TRIGGER_TYPE is set to Edge Trigger.
Supported Models

All supported


TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES

Positive values of dwell time indicate the number of samples that must be in the initial trigger state (for example, below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.

Data Type

Integer32
Data Type

M9703B


TRIGGER_MAGNITUDE_SLOPE

Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.

Data Type

Integer32
Supported Values
0 | NEGATIVE | A negative (falling) edge passing through the trigger level, triggers the digitizer.
1 | POSITIVE | A positive (rising) edge passing through the trigger level, triggers the digitizer.
Supported Models

M9703B


TRIGGER_OUTPUT_ENABLED

Specifies whether or not an accepted trigger appears at an output of the digitizer.

Data Type

Boolean
Supported Values
True | The trigger appears at the output of the digitizer.
False | The trigger output is disabled.
Supported Models

All supported


TRIGGER_OUTPUT_OFFSET

Specifies the offset in Volts at the trigger output of the digitizer.

Data Type

Real64
Supported Values

Allowed values are instrument dependent, refer to the specific instrument user guide for information.
Supported Models

All supported


TRIGGER_OUTPUT_SOURCE

Select the trigger signal to drive the trigger output connector on the front panel.

Data Type

String
Supported Models

All supported


TRIGGER_SLOPE

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the TRIGGER_TYPE attribute is set to Edge Trigger.

Data Type

Unsigned Integer32
Supported Values
0 | Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
1 | Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.
Supported Models

All supported


TRIGGER_SOURCE_COUNT

The number of trigger sources present on the instrument.

Data Type

Integer32, Read-Only
Supported Models

All supported


TRIGGER_SOURCE_OPERATOR

Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.

Data Type

Integer32
Supported Values
0 | AND | Trigger sources are logically AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
1 | OR | Trigger sources are logically OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
2 | None | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Active Trigger Source attribute, and its associated trigger conditions are satisfied.
Supported Models

All supported


TRIGGER_TYPE

The kind of event that triggers the digitizer.

Data Type

Integer32
Supported Values
1 | Edge Trigger | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the ACTIVE_TRIGGER_SOURCE attribute passes the voltage threshold specified with the TRIGGER_LEVEL attribute and has the slope specified with the TRIGGER_SLOPE attribute.
2 | Width Trigger | Configures the digitizer for width triggering.
3 | Runt Trigger | Configures the digitizer for runt triggering.
4 | Glitch Trigger | Configures the digitizer for glitch triggering.
5 | TV Trigger | Configures the digitizer for triggering on TV signals.
6 | Window Trigger | Configures the digitizer for window triggering.
Notes

TV triggering requires External trigger source.
Supported Models

All supported


TSR_ENABLED

Specifies whether TSR operation is enabled on the instrument.

Data Type

Boolean
Supported Values
True | TSR operation is enabled on the instrument.
False | TSR operation is not enabled on the instrument.
Supported Models

M9203A, M9703B, U5303A, U5309A


TSR_IS_ACQUISITION_COMPLETE

Indicates if a (single- or multi-record) waveform can be fetched from the instrument. Applicable only when TSR operation is enabled.

Data Type

Boolean Read-Only
Supported Values

True

False

Supported Models

M9203A, M9703B, U5303A, U5309A


TSR_MEMORY_OVERFLOW_OCCURRED

Indicates that no memory segment was available to acquire new data. The instrument could therefore not accept any new triggers, and some might have been missed.

Data Type

Boolean Read-Only
Supported Values

True

False

Supported Models

M9203A, M9703B, U5303A, U5309A


USER_CONTROL_COUNTERS_MODE

Specifies the Counters Mode.

Data Type

Integer32
Supported Values
0 | Normal | Configures the User Control Counters in Standard mode.
1 | Streaming | Configures the User Control Counters in Streaming mode.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_INTER_SEGMENT_DELAY_MODE

Specifies how the Inter Segment Delay is managed. In Software mode, the Inter Segment Delay is given as a fixed number of blocks, in the Inter Segment Delay Value attribute. In Firmware mode, the Inter Segment Delay is controlled directly by the User Firmware.

Data Type

Integer32
Supported Values
0 | Software | Configures the User Control Inter Segment Delay to use Software value.
1 | User Firmware | Configures the User Control Inter Segment Delay to be controlled by User Firmware.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

Number of Inter Segments Delay blocks.

Data Type

Integer32
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_POST_TRIGGER

Number of Post-Trigger blocks.

Data Type

Integer32
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_PRE_TRIGGER

Number of Pre-Trigger blocks.

Data Type

Integer32
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_START_ON_TRIGGER_ENABLED

Specifies whether the segmentation mechanism should work in Start On Trigger mode. While in Start On Trigger mode, the PreTrigger value is ignored.

Data Type

Boolean
Supported Values
True | The segmentation mechanism works in Start On Trigger mode.
False | The segmentation mechanism does not work in Start On Trigger mode.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_TRIGGER_ENABLE_SOURCE

Specifies the Source of the Trigger Enable, either from the Segmentation mechanism, or from the User Firmware.

Data Type

Integer32
Supported Values
0 | Segmentation | Configures the use of the Trigger Enable signal from the Segmentation mechanism.
1 | User Firmware | Configures the use of the Trigger Enable custom signal from the User Firmware.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_TRIGGER_FACTOR

Multiplicative factor for the PreTrigger and PostTrigger values, to be used with sparsing. The default value is 1.

Data Type

Integer32
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


USER_CONTROL_TRIGGER_SELECTION

Specifies the source of the Trigger, either from the analog circuitry, or from the digital user firmware.

Data Type

Integer32
Supported Values
0 | Analog | Configures the use of the Trigger coming from the analog source.
1 | Digital | Configures the use of the Trigger coming from the digital source.
Supported Models

M9203A, M9205A, M9206A, M9703A, M9703B, M9710A, U5303A, U5307A, U5309A


VERTICAL_COUPLING

Specifies how the digitizer couples the input signal for the channel.

Data Type

Integer32
Supported Values
0 | AC | The digitizer AC couples the input signal.
1 | DC | The digitizer DC couples the input signal.
2 | GND | The digitizer couples the channel to the ground.
Supported Models

All supported


VERTICAL_OFFSET

The location of the center of the range that you specify with the Vertical Range attribute.

The units are Volts, with respect to ground.

Data Type

Real64
Supported Values

Allowed values are instrument dependent, please refer to the instrument user guide for more information.
Notes

For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Supported Models

All supported


VERTICAL_RANGE

The absolute value of the input range the digitizer can acquire for the channel.

The units are Volts.

Data Type

Real64
Supported Values

Allowed values are instrument dependent, please refer to the instrument user guide for more information.
Notes

For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Supported Models

All supported


AgMD2 : Calibration Cancel

Aborts any running self-calibration and returns.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Calibration Load From File

Loads calibration values and info from file.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Path

Path of the file from where the information will be loaded.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Calibration Save To File

Saves calibration values and information in a binary file.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Path

Path of the binary file to which the information will be saved.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Edge Trigger Source

Sets the edge triggering properties. An edge trigger occurs when the trigger signal that you specify with the Source parameter passes through the voltage threshold that you specify with the level parameter and has the slope that you specify with the Slope parameter. This VI affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this VI. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this VI.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Source

Specifies the trigger source. The supported values are:

Name | Description
Channel<n> | Triggers from the channel specified, where <n> is a valid channel number.
External<n> | Triggers from external trigger input specified, where <n> is a valid external trigger input number.
PXI_STAR | Triggers from the PXI Bus Star Trigger.

Trigger Level

Specifies the trigger level.

Trigger Slope (Negative)

Specifies the trigger slope. The supported values are:

Name | Description
Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Reference Oscillator

Configures the digitizer's reference oscillator.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Oscillator Source (Reference Oscillator Source Internal)

Specifies the source of the reference frequency signal.

Oscillator Frequency

Specifies the frequency of the external reference oscillator. This parameter is only used if the Source is set to External.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Reference Oscillator Output Enabled

Configures whether or not the reference frequency signal appears at an output of the digitizer.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Output Enabled (Off)

Specifies whether or not the reference frequency signal appears at a reference output of the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Temperature Units

Configures the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Temperature Units (Temperature Units Celsius)

Temperature units to be used by the Board Temperature and Channel Temperature attributes. Supported values are:

Name | Description
Celsius | Temperature values returned from the digitizer are in degrees Celsius.
Fahrenheit | Temperature values returned from the digitizer are in degrees Fahrenheit.
Kelvin | Temperature values returned from the digitizer are in degrees Kelvin.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Time Interleaved Channel List

Combines this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Channel List

A comma-separated list of one or more channel names to combine with the channel specified by Channel Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Trigger Holdoff

Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Holdoff

The number of seconds the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int8

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int16

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int32

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Real64

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViBoolean

Gets a Boolean attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED
  • CALIBRATION_IS_REQUIRED
  • CHANNEL_ENABLED
  • DELAY_CONTROL_ENABLED
  • INPUT_FILTER_BYPASS
  • LOGIC_DEVICE_IFDL_ENABLED
  • LOGIC_DEVICE_IFDL_IS_ACTIVE
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED
  • LOGIC_DEVICE_SAMPLES_UNSIGNED
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED
  • SAMPLE_CLOCK_OUTPUT_ENABLED
  • SIMULATE
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO
  • TRIGGER_OUTPUT_ENABLED

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED: Enables or disables the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
  • CALIBRATION_IS_REQUIRED: Returns whether or not a self calibration is required.
  • CHANNEL_ENABLED: Specifies whether the digitizer acquires a waveform for the channel.
  • DELAY_CONTROL_ENABLED: Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
  • INPUT_FILTER_BYPASS: Specifies whether or not to bypass the input filter.
  • LOGIC_DEVICE_IFDL_ENABLED: Specifies whether the IFDL is enabled.
  • LOGIC_DEVICE_IFDL_IS_ACTIVE: Returns whether the IFDL is currently active.
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED: Enables the FIFO mode for MemoryBank. Used when streaming.
  • LOGIC_DEVICE_SAMPLES_UNSIGNED: When True, directs the LogicDevice to receive unsigned samples values from the ADC.
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED: Specifies whether or not the reference frequency signal appears at an output of the digitizer.
  • SAMPLE_CLOCK_OUTPUT_ENABLED: Specifies whether or not the sample clock appears at a reference output of the digitizer.
  • SIMULATE: If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO: Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
  • TRIGGER_OUTPUT_ENABLED: Specifies whether or not an accepted trigger appears at an output of the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViInt32

Gets an Int32 attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_MODE
  • CHANNEL_COUNT
  • CONTROL_IO_COUNT
  • DELAY_CONTROL_COUNT
  • DELAY_CONTROL_MAX
  • DELAY_CONTROL_MIN
  • DELAY_CONTROL_RANGE
  • DELAY_CONTROL_VALUE
  • INPUT_CONNECTOR_SELECTION
  • INSTRUMENT_INFO_CHASSIS_NUMBER
  • INSTRUMENT_INFO_NBR_ADC_BITS
  • IS_IDLE
  • IS_MEASURING
  • IS_WAITING_FOR_ARM
  • IS_WAITING_FOR_TRIGGER
  • LOGIC_DEVICE_COUNT
  • LOGIC_DEVICE_FIRMWARE_STORE_COUNT
  • LOGIC_DEVICE_IFDL_COUNT
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE
  • LOGIC_DEVICE_MEMORY_BANK_COUNT
  • LOGIC_DEVICE_STREAM_MODE
  • LOGIC_DEVICE_STREAMS_COUNT
  • MODULE_SYNCHRONIZATION_HANDLE
  • MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE
  • REFERENCE_OSCILLATOR_SOURCE
  • SAMPLE_CLOCK_SOURCE
  • TEMPERATURE_UNITS
  • TRIGGER_COUPLING
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES
  • TRIGGER_MAGNITUDE_SLOPE
  • TRIGGER_SLOPE
  • TRIGGER_SOURCE_COUNT
  • TRIGGER_SOURCE_OPERATOR
  • TRIGGER_TYPE
  • VERTICAL_COUPLING

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_MODE: The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
  • CHANNEL_COUNT: Returns the number of Control IO Connectors.
  • CONTROL_IO_COUNT: Simulate=true, DriverSetup= Model=U5303A
  • DELAY_CONTROL_COUNT: Returns the number of delay controls.
  • DELAY_CONTROL_MAX: Maximum value (DAC code) that can be set for the delay control.
  • DELAY_CONTROL_MIN: Minimum value (DAC code) that can be set for the delay control.
  • DELAY_CONTROL_RANGE: Selects the range for the delay control. Useful only for delay controls with multiple ranges.
  • DELAY_CONTROL_VALUE: The value (DAC code) set for the delay control.
  • INPUT_CONNECTOR_SELECTION: Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.
  • INSTRUMENT_INFO_CHASSIS_NUMBER: Chassis number.
  • INSTRUMENT_INFO_NBR_ADC_BITS: Number of bits of data per sample from this module's ADCs.
  • IS_IDLE: Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • IS_MEASURING: Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • IS_WAITING_FOR_ARM: Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • IS_WAITING_FOR_TRIGGER: Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • LOGIC_DEVICE_COUNT: Returns the number of logic devices.
  • LOGIC_DEVICE_FIRMWARE_STORE_COUNT: Number of available firmware stores in the LogicDevice.
  • LOGIC_DEVICE_IFDL_COUNT: Returns the number of LogicDevice IFDLs.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL: Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE: When MemoryBank access is controlled by software, specifies how the memory is currently accessed.
  • LOGIC_DEVICE_MEMORY_BANK_COUNT: Number of memory banks in LogicDevice.
  • LOGIC_DEVICE_STREAM_MODE: Specifies the mode the Streams are operating in.
  • LOGIC_DEVICE_STREAMS_COUNT: Number of Streams available in the LogicDevice.
  • MODULE_SYNCHRONIZATION_HANDLE: The handle of the current module.
  • MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE: The handle of the master module, when synchronized. This value will be identical to the attribute Handle if this module is the master, and equal to 0 when not synchronized.
  • REFERENCE_OSCILLATOR_SOURCE: Specifies the reference frequency source used.
  • SAMPLE_CLOCK_SOURCE: Specifies the clock used to pace acquisition sampling.
  • TEMPERATURE_UNITS: Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
  • TRIGGER_COUPLING: Specifies how the digitizer couples the trigger source.
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES: Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
  • TRIGGER_MAGNITUDE_SLOPE: Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
  • TRIGGER_SLOPE: Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
  • TRIGGER_SOURCE_COUNT: The number of trigger sources.
  • TRIGGER_SOURCE_OPERATOR: Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.
  • TRIGGER_TYPE: The kind of event that triggers the digitizer.
  • VERTICAL_COUPLING: Specifies how the digitizer couples the input signal for the channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViInt64

Gets an Int64 attribute from the instrument driver. The following attributes are supported:

  • MAX_FIRST_VALID_POINT_VAL
  • MAX_SAMPLES_PER_CHANNEL
  • MIN_RECORD_SIZE
  • NUM_ACQUIRED_RECORDS
  • NUM_RECORDS_TO_ACQUIRE
  • RECORD_SIZE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • MAX_FIRST_VALID_POINT_VAL: Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieve the entire acquisition.
  • MAX_SAMPLES_PER_CHANNEL: Returns the maximum number of samples per channel that can be captured.
  • MIN_RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, this attribute returns 1.
  • NUM_ACQUIRED_RECORDS: Gets the total number of records acquired since the acquisition was last initiated. You may call this method while an acquisition is in progress.
  • NUM_RECORDS_TO_ACQUIRE: Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
  • RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, this attribute returns 1.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViReal64

Gets a Real64 attribute from the instrument driver. The following attributes are supported:

  • BOARD_TEMPERATURE
  • CHANNEL_TEMPERATURE
  • INPUT_FILTER_MAX_FREQUENCY
  • INPUT_FILTER_MIN_FREQUENCY
  • INPUT_IMPEDANCE
  • MONITORING_VALUE_CURRENT_VALUE
  • MONITORING_VALUE_LIMIT_HIGH
  • MONITORING_VALUE_LIMIT_LOW
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY
  • SAMPLE_RATE
  • TRIGGER_DELAY
  • TRIGGER_HYSTERESIS
  • TRIGGER_LEVEL
  • TRIGGER_OUTPUT_OFFSET
  • VERTICAL_OFFSET
  • VERTICAL_RANGE

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • BOARD_TEMPERATURE: Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.
  • CHANNEL_TEMPERATURE: Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
  • INPUT_FILTER_MAX_FREQUENCY: Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_FILTER_MIN_FREQUENCY: Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_IMPEDANCE: The input impedance of this channel. The units are Ohms.
  • MONITORING_VALUE_CURRENT_VALUE: Returns the current monitored value of the MonitoringValue.
  • MONITORING_VALUE_LIMIT_HIGH: Returns the limit value above which the instrument behavior may not be consistent with the specifications.
  • MONITORING_VALUE_LIMIT_LOW: Returns the limit value below which the instrument behavior may not be consistent with the specifications.
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER: Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
  • SAMPLE_RATE: Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
  • TRIGGER_DELAY: Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
  • TRIGGER_HYSTERESIS: Specifies the trigger hysteresis in Volts.
  • TRIGGER_LEVEL: Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
  • TRIGGER_OUTPUT_OFFSET: Specifies the offset in Volts at the trigger output of the digitizer.
  • VERTICAL_OFFSET: The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
  • VERTICAL_RANGE: The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViString

Gets a String attribute from the instrument driver. The following attributes are supported:

  • ACTIVE_TRIGGER_SOURCE
  • CHANNEL_CONNECTOR_NAME
  • CONTROL_IO_AVAILABLE_SIGNALS
  • CONTROL_IO_SIGNAL
  • DRIVER_SETUP
  • INSTRUMENT_FIRMWARE_REVISION
  • INSTRUMENT_INFO_IO_VERSION
  • INSTRUMENT_INFO_OPTIONS
  • INSTRUMENT_INFO_SERIAL_NUMBER_STRING
  • INSTRUMENT_MANUFACTURER
  • INSTRUMENT_MODEL
  • IO_RESOURCE_DESCRIPTOR
  • LOGICAL_NAME
  • MONITORING_VALUE_UNIT
  • SPECIFIC_DRIVER_DESCRIPTION
  • SPECIFIC_DRIVER_REVISION
  • SPECIFIC_DRIVER_VENDOR
  • SUPPORTED_INSTRUMENT_MODELS
  • TIME_INTERLEAVED_CHANNEL_LIST
  • TRIGGER_OUTPUT_SOURCE

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACTIVE_TRIGGER_SOURCE: Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability.
  • CHANNEL_CONNECTOR_NAME: The connector name as it appears on the instrument's front panel.
  • CONTROL_IO_AVAILABLE_SIGNALS: Comma separated list of available signal names that can be used for the Signal attribute of this repeated capability.
  • CONTROL_IO_SIGNAL: Signal present on a Control IO connector.
  • DRIVER_SETUP: The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
  • INSTRUMENT_FIRMWARE_REVISION: The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
  • INSTRUMENT_INFO_IO_VERSION: Version of the IO Driver used by this module.
  • INSTRUMENT_INFO_OPTIONS: Comma separated list of options installed in this instrument.
  • INSTRUMENT_INFO_SERIAL_NUMBER_STRING: The serial number of the instrument.
  • INSTRUMENT_MANUFACTURER: The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
  • INSTRUMENT_MODEL: The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.
  • IO_RESOURCE_DESCRIPTOR: The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
  • LOGICAL_NAME: Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
  • MONITORING_VALUE_UNIT: Returns the unit of this monitoring value.
  • SPECIFIC_DRIVER_DESCRIPTION: Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SPECIFIC_DRIVER_REVISION: Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SPECIFIC_DRIVER_VENDOR: Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SUPPORTED_INSTRUMENT_MODELS: A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
  • TIME_INTERLEAVED_CHANNEL_LIST: This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one or more channel names.
  • TRIGGER_OUTPUT_SOURCE: Selects the trigger signal to drive the trigger output connector on the front panel.

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Instrument Info Attribute ID Value From String

Converts the string representation of a property ID to its numeric value.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Str

String representation of the property ID, without the prefix 'PREFIX_ATTR_'.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Value

Numeric value of the property ID.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Instrument Info Attribute ID Value To String

Converts a property ID into its string representation.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Value

Property ID value.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Str

String representation of the property ID , without the prefix 'PREFIX_ATTR_'.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : IVI Error Converter

Convert error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

IVI error code (0)

Error code returned from an IVI instrument driver operation.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Module Synchronization Configure Slaves

Configures the modules which are identified by their handles, as synchronized slaves of the current module (which becomes a master module).

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

SlavesCount

Number of Slaves in the array.

Slaves

Array of slaves.

Numeric

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Query Board Temperature

Query the temperature of the entire board. The units are governed by the Temperature Units attribute.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns the current temperature of the entire board. The units are governed by the Temperature Units attribute.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Query Channel Temperature

Queries the temperature of a specific channel. The units are governed by the Temperature Units attribute.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The name of the channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns the current temperature of the specified channel. The units are governed by the Temperature Units attribute.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Boolean

Sets a Boolean attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED
  • CHANNEL_ENABLED
  • DELAY_CONTROL_ENABLED
  • INPUT_FILTER_BYPASS
  • LOGIC_DEVICE_IFDL_ENABLED
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED
  • LOGIC_DEVICE_SAMPLES_UNSIGNED
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED
  • SAMPLE_CLOCK_OUTPUT_ENABLED
  • SIMULATE
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO
  • TRIGGER_OUTPUT_ENABLED

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED: Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
  • CHANNEL_ENABLED: Specifies whether the digitizer acquires a waveform for the channel.
  • DELAY_CONTROL_ENABLED: Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
  • INPUT_FILTER_BYPASS: Specifies whether or not to bypass the input filter.
  • LOGIC_DEVICE_IFDL_ENABLED: Specifies whether the IFDL is enabled.
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED: Enables the FIFO mode for MemoryBank. Used when streaming.
  • LOGIC_DEVICE_SAMPLES_UNSIGNED: When True, directs the LogicDevice to receive unsigned samples values from the ADC.
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED: Specifies whether or not the reference frequency signal appears at an output of the digitizer.
  • SAMPLE_CLOCK_OUTPUT_ENABLED: Specifies whether or not the sample clock appears at a reference output of the digitizer.
  • SIMULATE: If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO: Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
  • TRIGGER_OUTPUT_ENABLED: Specifies whether or not an accepted trigger appears at an output of the digitizer.

AttributeValue (Off)

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Int32

Sets an Int32 attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_MODE
  • DELAY_CONTROL_RANGE
  • DELAY_CONTROL_VALUE
  • INPUT_CONNECTOR_SELECTION
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE
  • LOGIC_DEVICE_STREAM_MODE
  • REFERENCE_OSCILLATOR_SOURCE
  • SAMPLE_CLOCK_SOURCE
  • TEMPERATURE_UNITS
  • TRIGGER_COUPLING
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES
  • TRIGGER_MAGNITUDE_SLOPE
  • TRIGGER_SLOPE
  • TRIGGER_SOURCE_OPERATOR
  • TRIGGER_TYPE
  • VERTICAL_COUPLING

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_MODE: The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
  • DELAY_CONTROL_RANGE: Selects the range for the delay control. Useful only for delay controls with multiple ranges.
  • DELAY_CONTROL_VALUE: The value (DAC code) set for the delay control.
  • INPUT_CONNECTOR_SELECTION: Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL: Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE: When MemoryBank access is controlled by software, this attribute specifies how the memory is currently accessed.
  • LOGIC_DEVICE_STREAM_MODE: Specifies the mode the Streams are operating in.
  • REFERENCE_OSCILLATOR_SOURCE: Specifies the reference frequency source used.
  • SAMPLE_CLOCK_SOURCE: Specifies the clock used to pace acquisition sampling.
  • TEMPERATURE_UNITS: Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
  • TRIGGER_COUPLING: Specifies how the digitizer couples the trigger source.
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES: Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
  • TRIGGER_MAGNITUDE_SLOPE: Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
  • TRIGGER_SLOPE: Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
  • TRIGGER_SOURCE_OPERATOR: Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.
  • TRIGGER_TYPE: The kind of event that triggers the digitizer.
  • VERTICAL_COUPLING: Specifies how the digitizer couples the input signal for the channel.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Int64

Sets an Int64 attribute from the instrument driver. The following attributes are supported:

  • MAX_FIRST_VALID_POINT_VAL
  • NUM_RECORDS_TO_ACQUIRE
  • RECORD_SIZE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • MAX_FIRST_VALID_POINT_VAL: Returns the maximum value that the First Valid Point parameter of the readout VIs may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
  • NUM_RECORDS_TO_ACQUIRE: Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
  • RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Real64

Sets a Real64 attribute from the instrument driver. The following attributes are supported:

  • INPUT_FILTER_MAX_FREQUENCY
  • INPUT_FILTER_MIN_FREQUENCY
  • INPUT_IMPEDANCE
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY
  • SAMPLE_RATE
  • TRIGGER_DELAY
  • TRIGGER_HYSTERESIS
  • TRIGGER_LEVEL
  • TRIGGER_OUTPUT_OFFSET
  • VERTICAL_OFFSET
  • VERTICAL_RANGE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • INPUT_FILTER_MAX_FREQUENCY: Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_FILTER_MIN_FREQUENCY: Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_IMPEDANCE: The input impedance of this channel. The units are Ohms.
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER: Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
  • SAMPLE_RATE: Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
  • TRIGGER_DELAY: Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
  • TRIGGER_HYSTERESIS: Specifies the trigger hysteresis in Volts.
  • TRIGGER_LEVEL: Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
  • TRIGGER_OUTPUT_OFFSET: Specifies the offset in Volts at the trigger output of the digitizer.
  • VERTICAL_OFFSET: The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
  • VERTICAL_RANGE: The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi String

Sets a String attribute from the instrument driver. The following attributes are supported:

  • ACTIVE_TRIGGER_SOURCE
  • CONTROL_IO_SIGNAL
  • TIME_INTERLEAVED_CHANNEL_LIST
  • TRIGGER_OUTPUT_SOURCE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACTIVE_TRIGGER_SOURCE: Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability.

  • CONTROL_IO_SIGNAL: Signal present on a Control IO connector.

  • TIME_INTERLEAVED_CHANNEL_LIST: Use to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one or more channel names.

  • TRIGGER_OUTPUT_SOURCE: Select the trigger signal to drive the trigger output connector on the front panel.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Name

VI description overview text.

Data Type

I/O

Boolean

Integer32

Integer64

String

Real64

Supported Values


AgMD2 : *Name of VI*

*Description*

* [image] *

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Closed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Image library:

Input icons |
 | I/O in
 | error in
 | boolean in
 | integer 32 in
 | integer 64 in
 | string in
 | double in
 | unsigned int 32 in
Output icons |
 | I/O out
 | error out
 | boolean out
 | integer 8 out
 | integer 16 out
 | integer 32 out
 | integer 64 out
 | string out
 | double out
 | unsigned int 32 out
 | array of integer 8 out
 | array of integer 16 out
 | array of integer 32 out
 | array of integer 64 out
 | array of doubles out


EEPROM_MODULE_GENERATION_OPTIONS

This attribute is private and for Keysight-internal use only.

Data Type

String


EEPROM_MODULE_GENERATION_SERIAL_NUMBER

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_CALIBRATION_USER_SIGNAL

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_STORE_BAR_CODE

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_STORE_COUNT

This attribute is private and for Keysight-internal use only.

Data Type

Integer32, Read-Only


PRIVATE_STORE_PART_NUMBER

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_STORE_PART_NUMBER_REVISION

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_STORE_PRODUCTION_DATE

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_STORE_SERIAL_NUMBER

This attribute is private and for Keysight-internal use only.

Data Type

String


PRIVATE_STORE_TEST_DATE

This attribute is private and for Keysight-internal use only.

Data Type

String